aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/rt305x/profiles/tenda.mk
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-01-19 17:05:07 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-01-19 17:05:07 +0000
commited6d399f8d5a0952b7d101e1e9bd4d9632b741e8 (patch)
tree02317e1749898ee9a1895df29a7295ceab12f568 /target/linux/ramips/rt305x/profiles/tenda.mk
parent9891603eb571ddacfde6a3a6c3efb3cc25be0af4 (diff)
downloadupstream-ed6d399f8d5a0952b7d101e1e9bd4d9632b741e8.tar.gz
upstream-ed6d399f8d5a0952b7d101e1e9bd4d9632b741e8.tar.bz2
upstream-ed6d399f8d5a0952b7d101e1e9bd4d9632b741e8.zip
ramips: add profile and build image for the Tenda 3G300M
Factory image should be used to flash from original firmware. [juhosg: use the GENERIC_4M template] Signed-off-by: Cezary Jackiewicz <cezary.jackiewicz@gmail.com> Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 35246
Diffstat (limited to 'target/linux/ramips/rt305x/profiles/tenda.mk')
-rw-r--r--target/linux/ramips/rt305x/profiles/tenda.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ramips/rt305x/profiles/tenda.mk b/target/linux/ramips/rt305x/profiles/tenda.mk
index 5e45b5f913..10a4cb3077 100644
--- a/target/linux/ramips/rt305x/profiles/tenda.mk
+++ b/target/linux/ramips/rt305x/profiles/tenda.mk
@@ -5,6 +5,19 @@
# See /LICENSE for more information.
#
+define Profile/3G300M
+ NAME:=Tenda 3G300M
+ PACKAGES:=\
+ kmod-usb-core kmod-usb-rt305x-dwc_otg \
+ kmod-ledtrig-usbdev
+endef
+
+define Profile/3G300M/Description
+ Package set for Tenda 3G300M board
+endef
+
+$(eval $(call Profile,3G300M))
+
define Profile/W306R_V20
NAME:=Tenda W306R V2.0
PACKAGES:=