aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/rt305x/profiles/freestation5.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-03-29 16:03:04 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-03-29 16:03:04 +0000
commit2f2034752cca7b1003c7342a9f37cd6e746724ab (patch)
tree1bcc1eb8818102a6469cf3cfcf9be6b4acb938e9 /target/linux/ramips/rt305x/profiles/freestation5.mk
parent88b3c3aad1f846b3217249f41da7d6e7be8c950d (diff)
downloadupstream-2f2034752cca7b1003c7342a9f37cd6e746724ab.tar.gz
upstream-2f2034752cca7b1003c7342a9f37cd6e746724ab.tar.bz2
upstream-2f2034752cca7b1003c7342a9f37cd6e746724ab.zip
ramips: add support for the ARC FreeStation5 board, also fix WCR-150GN network setup while we're at it - thanks Pau Escrich <p4u@dabax.net> for the implementation
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31144 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/rt305x/profiles/freestation5.mk')
-rw-r--r--target/linux/ramips/rt305x/profiles/freestation5.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/ramips/rt305x/profiles/freestation5.mk b/target/linux/ramips/rt305x/profiles/freestation5.mk
new file mode 100644
index 0000000000..6da1e68c2e
--- /dev/null
+++ b/target/linux/ramips/rt305x/profiles/freestation5.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/FREESTATION5
+ NAME:=FreeStation5
+ PACKAGES:=\
+ kmod-usb-rt305x-dwc_otg kmod-rt2500-usb kmod-rt2800-usb kmod-rt2x00-usb
+endef
+
+define Profile/FREESTATION5/Description
+ Package set for ARC Flex FreeStation5
+endef
+
+$(eval $(call Profile,FREESTATION5))