aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/rt305x/profiles/d-link.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-08-17 06:01:38 +0000
committerJohn Crispin <john@openwrt.org>2015-08-17 06:01:38 +0000
commit57e614c1790e316ef8b5b8cb0cd4ae4dcb185d3d (patch)
treef79dc5fd960c594a010ad7b296f13b44e6c77847 /target/linux/ramips/rt305x/profiles/d-link.mk
parent0d464c360f0de4d90c8b25b2b2960ac7b5392cae (diff)
downloadupstream-57e614c1790e316ef8b5b8cb0cd4ae4dcb185d3d.tar.gz
upstream-57e614c1790e316ef8b5b8cb0cd4ae4dcb185d3d.tar.bz2
upstream-57e614c1790e316ef8b5b8cb0cd4ae4dcb185d3d.zip
ramips: fix various mistakes in subtargets *.mk profiles
This patch: * fixes wrong indentation * fixes wrong names and descriptions (ex. Dlink -> D-Link) * changes filenames to manufacturer names * moves oem/unknown manufacturers boards to misc.mk profiles * combines profiles for boards from the same manufacturers in one file (ex. Olimex) * fix profile files structure (keep the same convention as in other targets, ex. ar71xx) in various .mk profiles, in ramips target. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com> SVN-Revision: 46631
Diffstat (limited to 'target/linux/ramips/rt305x/profiles/d-link.mk')
-rw-r--r--target/linux/ramips/rt305x/profiles/d-link.mk68
1 files changed, 68 insertions, 0 deletions
diff --git a/target/linux/ramips/rt305x/profiles/d-link.mk b/target/linux/ramips/rt305x/profiles/d-link.mk
new file mode 100644
index 0000000000..05d919ba42
--- /dev/null
+++ b/target/linux/ramips/rt305x/profiles/d-link.mk
@@ -0,0 +1,68 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/DCS930
+ NAME:=D-Link DCS-930
+ PACKAGES:=kmod-video-core kmod-video-uvc \
+ kmod-sound-core kmod-usb-audio \
+ kmod-usb-core kmod-usb-dwc2
+endef
+
+define Profile/DCS930/Description
+ Package set for D-Link DCS-930 board
+endef
+$(eval $(call Profile,DCS930))
+
+
+define Profile/DCS930LB1
+ NAME:=D-Link DCS-930L B1
+ PACKAGES:=kmod-video-core kmod-video-uvc \
+ kmod-sound-core kmod-usb-audio \
+ kmod-usb-core kmod-usb-ohci kmod-usb2
+endef
+
+define Profile/DCS930LB1/Description
+ Package set for D-Link DCS-930L B1 board
+endef
+$(eval $(call Profile,DCS930LB1))
+
+
+define Profile/DIR610A1
+ NAME:=D-Link DIR-610 A1
+ PACKAGES:=kmod-ledtrig-netdev kmod-ledtrig-timer
+endef
+
+define Profile/DIR610A1/Description
+ Package set for D-Link DIR610 A1 board
+endef
+$(eval $(call Profile,DIR610A1))
+
+
+define Profile/DIR-615-D
+ NAME:=D-Link DIR-615 D
+ PACKAGES:=\
+ -kmod-usb-core -kmod-usb-dwc2 \
+ -kmod-ledtrig-usbdev
+endef
+
+define Profile/DIR-615-D/Description
+ Package set for D-Link DIR-615 D board
+endef
+$(eval $(call Profile,DIR-615-D))
+
+
+define Profile/DIR615H1
+ NAME:=D-Link DIR-615 H1
+ PACKAGES:=\
+ -kmod-usb-core -kmod-usb-dwc2 \
+ -kmod-ledtrig-usbdev
+endef
+
+define Profile/DIR615H1/Description
+ Package set for D-Link DIR-615 H1 board
+endef
+$(eval $(call Profile,DIR615H1))