aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/patches-4.9/0090-ethernet.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2017-02-13 12:38:27 +0100
committerJohn Crispin <john@phrozen.org>2017-02-14 12:17:52 +0100
commit9c2422709075196022fcbc2d0f5f83e01d02b951 (patch)
tree4f18a4dd9d22fcbe10c0365596dd133cf28383be /target/linux/ramips/patches-4.9/0090-ethernet.patch
parentd5221d5a419c14456bccba9f6825567839082fb0 (diff)
downloadupstream-9c2422709075196022fcbc2d0f5f83e01d02b951.tar.gz
upstream-9c2422709075196022fcbc2d0f5f83e01d02b951.tar.bz2
upstream-9c2422709075196022fcbc2d0f5f83e01d02b951.zip
ramips: add v4.9 support
NAND support is missing Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux/ramips/patches-4.9/0090-ethernet.patch')
-rw-r--r--target/linux/ramips/patches-4.9/0090-ethernet.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/target/linux/ramips/patches-4.9/0090-ethernet.patch b/target/linux/ramips/patches-4.9/0090-ethernet.patch
new file mode 100644
index 0000000000..af8ae0b030
--- /dev/null
+++ b/target/linux/ramips/patches-4.9/0090-ethernet.patch
@@ -0,0 +1,41 @@
+From b6f779ea9c329451b89404583b45b9eb00155b32 Mon Sep 17 00:00:00 2001
+From: John Crispin <blogic@openwrt.org>
+Date: Wed, 18 Nov 2015 03:58:26 +0100
+Subject: [PATCH 510/513] net-next: mediatek: add Kconfig and Makefile
+
+This patch adds the Makefile and Kconfig required to make the driver build.
+
+Signed-off-by: John Crispin <blogic@openwrt.org>
+Signed-off-by: Felix Fietkau <nbd@nbd.name>
+Signed-off-by: Michael Lee <igvtee@gmail.com>
+---
+ drivers/net/ethernet/Kconfig | 1 +
+ drivers/net/ethernet/Makefile | 1 +
+ drivers/net/ethernet/mtk/Kconfig | 62 ++++++++++++++++++++++++++++++++
+ drivers/net/ethernet/mtk/Makefile | 20 +++++++++++
+ 4 files changed, 84 insertions(+)
+ create mode 100644 drivers/net/ethernet/mtk/Kconfig
+ create mode 100644 drivers/net/ethernet/mtk/Makefile
+
+--- a/drivers/net/ethernet/Kconfig
++++ b/drivers/net/ethernet/Kconfig
+@@ -107,7 +107,7 @@
+ Support for the MII0 inside the Lantiq SoC
+
+ source "drivers/net/ethernet/marvell/Kconfig"
+-source "drivers/net/ethernet/mediatek/Kconfig"
++source "drivers/net/ethernet/mtk/Kconfig"
+ source "drivers/net/ethernet/mellanox/Kconfig"
+ source "drivers/net/ethernet/micrel/Kconfig"
+ source "drivers/net/ethernet/microchip/Kconfig"
+--- a/drivers/net/ethernet/Makefile
++++ b/drivers/net/ethernet/Makefile
+@@ -47,7 +47,7 @@
+ obj-$(CONFIG_KORINA) += korina.o
+ obj-$(CONFIG_LANTIQ_ETOP) += lantiq_etop.o
+ obj-$(CONFIG_NET_VENDOR_MARVELL) += marvell/
+-obj-$(CONFIG_NET_VENDOR_MEDIATEK) += mediatek/
++obj-$(CONFIG_NET_VENDOR_MEDIATEK) += mtk/
+ obj-$(CONFIG_NET_VENDOR_MELLANOX) += mellanox/
+ obj-$(CONFIG_NET_VENDOR_MICREL) += micrel/
+ obj-$(CONFIG_NET_VENDOR_MICROCHIP) += microchip/