aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/patches-3.9/0205-owrt-MIPS-add-OWRTDTB-secion.patch
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2013-06-30 13:10:12 +0000
committerJonas Gorski <jogo@openwrt.org>2013-06-30 13:10:12 +0000
commit0d9f760f272f3ccb3abcaca8e678734b666e234c (patch)
tree14237dc1b483b6fefbf696164b80f594e9826e49 /target/linux/ramips/patches-3.9/0205-owrt-MIPS-add-OWRTDTB-secion.patch
parent6a4e78dca6ecd4325504f0a74cd1816275157eea (diff)
downloadupstream-0d9f760f272f3ccb3abcaca8e678734b666e234c.tar.gz
upstream-0d9f760f272f3ccb3abcaca8e678734b666e234c.tar.bz2
upstream-0d9f760f272f3ccb3abcaca8e678734b666e234c.zip
kernel: update linux 3.9 to 3.9.8
Includes memory allocation fixes as well as several networking fixes. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 37103
Diffstat (limited to 'target/linux/ramips/patches-3.9/0205-owrt-MIPS-add-OWRTDTB-secion.patch')
-rw-r--r--target/linux/ramips/patches-3.9/0205-owrt-MIPS-add-OWRTDTB-secion.patch12
1 files changed, 6 insertions, 6 deletions
diff --git a/target/linux/ramips/patches-3.9/0205-owrt-MIPS-add-OWRTDTB-secion.patch b/target/linux/ramips/patches-3.9/0205-owrt-MIPS-add-OWRTDTB-secion.patch
index b1e8058c7b..d048aee459 100644
--- a/target/linux/ramips/patches-3.9/0205-owrt-MIPS-add-OWRTDTB-secion.patch
+++ b/target/linux/ramips/patches-3.9/0205-owrt-MIPS-add-OWRTDTB-secion.patch
@@ -24,16 +24,16 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
NESTED(kernel_entry, 16, sp) # kernel entry point
--- a/arch/mips/ralink/Makefile
+++ b/arch/mips/ralink/Makefile
-@@ -15,4 +15,4 @@ obj-$(CONFIG_SOC_MT7620) += mt7620.o
+@@ -17,4 +17,4 @@ obj-$(CONFIG_EARLY_PRINTK) += early_prin
- obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
+ obj-$(CONFIG_DEBUG_FS) += bootrom.o
-obj-y += dts/
+#obj-y += dts/
--- a/arch/mips/ralink/of.c
+++ b/arch/mips/ralink/of.c
-@@ -77,6 +77,8 @@ void __init device_tree_init(void)
- free_bootmem(base, size);
+@@ -83,6 +83,8 @@ void __init device_tree_init(void)
+ //free_bootmem(base, size);
}
+extern struct boot_param_header __image_dtb;
@@ -41,7 +41,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
void __init plat_mem_setup(void)
{
set_io_port_base(KSEG1);
-@@ -85,7 +87,7 @@ void __init plat_mem_setup(void)
+@@ -91,7 +93,7 @@ void __init plat_mem_setup(void)
* Load the builtin devicetree. This causes the chosen node to be
* parsed resulting in our memory appearing
*/
@@ -49,4 +49,4 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
+ __dt_setup_arch(&__image_dtb);
if (soc_info.mem_size)
- add_memory_region(soc_info.mem_base, soc_info.mem_size,
+ add_memory_region(soc_info.mem_base, soc_info.mem_size * SZ_1M,