aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/patches-3.9/0150-PCI-MIPS-adds-rt3883-pci-support.patch
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2013-06-30 13:10:12 +0000
committerJonas Gorski <jogo@openwrt.org>2013-06-30 13:10:12 +0000
commit0d9f760f272f3ccb3abcaca8e678734b666e234c (patch)
tree14237dc1b483b6fefbf696164b80f594e9826e49 /target/linux/ramips/patches-3.9/0150-PCI-MIPS-adds-rt3883-pci-support.patch
parent6a4e78dca6ecd4325504f0a74cd1816275157eea (diff)
downloadupstream-0d9f760f272f3ccb3abcaca8e678734b666e234c.tar.gz
upstream-0d9f760f272f3ccb3abcaca8e678734b666e234c.tar.bz2
upstream-0d9f760f272f3ccb3abcaca8e678734b666e234c.zip
kernel: update linux 3.9 to 3.9.8
Includes memory allocation fixes as well as several networking fixes. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 37103
Diffstat (limited to 'target/linux/ramips/patches-3.9/0150-PCI-MIPS-adds-rt3883-pci-support.patch')
-rw-r--r--target/linux/ramips/patches-3.9/0150-PCI-MIPS-adds-rt3883-pci-support.patch12
1 files changed, 1 insertions, 11 deletions
diff --git a/target/linux/ramips/patches-3.9/0150-PCI-MIPS-adds-rt3883-pci-support.patch b/target/linux/ramips/patches-3.9/0150-PCI-MIPS-adds-rt3883-pci-support.patch
index 20ae55875f..46a9198e04 100644
--- a/target/linux/ramips/patches-3.9/0150-PCI-MIPS-adds-rt3883-pci-support.patch
+++ b/target/linux/ramips/patches-3.9/0150-PCI-MIPS-adds-rt3883-pci-support.patch
@@ -13,11 +13,9 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
3 files changed, 642 insertions(+)
create mode 100644 arch/mips/pci/pci-rt3883.c
-diff --git a/arch/mips/pci/Makefile b/arch/mips/pci/Makefile
-index 77974ba..3cbfd9b 100644
--- a/arch/mips/pci/Makefile
+++ b/arch/mips/pci/Makefile
-@@ -42,6 +42,7 @@ obj-$(CONFIG_SNI_RM) += fixup-sni.o ops-sni.o
+@@ -42,6 +42,7 @@ obj-$(CONFIG_SNI_RM) += fixup-sni.o ops
obj-$(CONFIG_LANTIQ) += fixup-lantiq.o
obj-$(CONFIG_PCI_LANTIQ) += pci-lantiq.o ops-lantiq.o
obj-$(CONFIG_SOC_RT2880) += pci-rt2880.o
@@ -25,9 +23,6 @@ index 77974ba..3cbfd9b 100644
obj-$(CONFIG_TANBAC_TB0219) += fixup-tb0219.o
obj-$(CONFIG_TANBAC_TB0226) += fixup-tb0226.o
obj-$(CONFIG_TANBAC_TB0287) += fixup-tb0287.o
-diff --git a/arch/mips/pci/pci-rt3883.c b/arch/mips/pci/pci-rt3883.c
-new file mode 100644
-index 0000000..212c90b
--- /dev/null
+++ b/arch/mips/pci/pci-rt3883.c
@@ -0,0 +1,640 @@
@@ -671,8 +666,6 @@ index 0000000..212c90b
+}
+
+postcore_initcall(rt3883_pci_init);
-diff --git a/arch/mips/ralink/Kconfig b/arch/mips/ralink/Kconfig
-index c0ac93a..2fbe93c 100644
--- a/arch/mips/ralink/Kconfig
+++ b/arch/mips/ralink/Kconfig
@@ -21,6 +21,7 @@ choice
@@ -683,6 +676,3 @@ index c0ac93a..2fbe93c 100644
config SOC_MT7620
bool "MT7620"
---
-1.7.10.4
-