aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/patches-3.9/0148-DMA-MIPS-ralink-add-dmaengine-driver.patch
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2013-06-30 13:10:12 +0000
committerJonas Gorski <jogo@openwrt.org>2013-06-30 13:10:12 +0000
commit0d9f760f272f3ccb3abcaca8e678734b666e234c (patch)
tree14237dc1b483b6fefbf696164b80f594e9826e49 /target/linux/ramips/patches-3.9/0148-DMA-MIPS-ralink-add-dmaengine-driver.patch
parent6a4e78dca6ecd4325504f0a74cd1816275157eea (diff)
downloadupstream-0d9f760f272f3ccb3abcaca8e678734b666e234c.tar.gz
upstream-0d9f760f272f3ccb3abcaca8e678734b666e234c.tar.bz2
upstream-0d9f760f272f3ccb3abcaca8e678734b666e234c.zip
kernel: update linux 3.9 to 3.9.8
Includes memory allocation fixes as well as several networking fixes. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 37103
Diffstat (limited to 'target/linux/ramips/patches-3.9/0148-DMA-MIPS-ralink-add-dmaengine-driver.patch')
-rw-r--r--target/linux/ramips/patches-3.9/0148-DMA-MIPS-ralink-add-dmaengine-driver.patch13
1 files changed, 0 insertions, 13 deletions
diff --git a/target/linux/ramips/patches-3.9/0148-DMA-MIPS-ralink-add-dmaengine-driver.patch b/target/linux/ramips/patches-3.9/0148-DMA-MIPS-ralink-add-dmaengine-driver.patch
index a56ba188f1..bd3a6055bc 100644
--- a/target/linux/ramips/patches-3.9/0148-DMA-MIPS-ralink-add-dmaengine-driver.patch
+++ b/target/linux/ramips/patches-3.9/0148-DMA-MIPS-ralink-add-dmaengine-driver.patch
@@ -13,8 +13,6 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
create mode 100644 drivers/dma/ralink_gdma.c
create mode 100644 drivers/dma/ralink_gdma.h
-diff --git a/drivers/dma/Kconfig b/drivers/dma/Kconfig
-index aeaea32..751cdc4 100644
--- a/drivers/dma/Kconfig
+++ b/drivers/dma/Kconfig
@@ -322,6 +322,13 @@ config MMP_PDMA
@@ -31,8 +29,6 @@ index aeaea32..751cdc4 100644
config DMA_ENGINE
bool
-diff --git a/drivers/dma/Makefile b/drivers/dma/Makefile
-index 488e3ff..f69e07e 100644
--- a/drivers/dma/Makefile
+++ b/drivers/dma/Makefile
@@ -37,3 +37,4 @@ obj-$(CONFIG_DMA_SA11X0) += sa11x0-dma.o
@@ -40,9 +36,6 @@ index 488e3ff..f69e07e 100644
obj-$(CONFIG_DMA_OMAP) += omap-dma.o
obj-$(CONFIG_MMP_PDMA) += mmp_pdma.o
+obj-$(CONFIG_RALINK_GDMA) += ralink_gdma.o
-diff --git a/drivers/dma/ralink_gdma.c b/drivers/dma/ralink_gdma.c
-new file mode 100644
-index 0000000..be7c317
--- /dev/null
+++ b/drivers/dma/ralink_gdma.c
@@ -0,0 +1,229 @@
@@ -275,9 +268,6 @@ index 0000000..be7c317
+MODULE_AUTHOR("John Crispin <blogic@openwrt.org>");
+MODULE_DESCRIPTION("DMA engine driver for Ralink DMA engine");
+MODULE_LICENSE("GPL");
-diff --git a/drivers/dma/ralink_gdma.h b/drivers/dma/ralink_gdma.h
-new file mode 100644
-index 0000000..73e1948
--- /dev/null
+++ b/drivers/dma/ralink_gdma.h
@@ -0,0 +1,55 @@
@@ -336,6 +326,3 @@ index 0000000..73e1948
+#define RT_DMA_DONEINT (RALINK_GDMA_BASE + 0x204)
+
+#endif
---
-1.7.10.4
-