aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/patches-3.8/105-usb_dwc_otg.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-02-25 21:28:42 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-02-25 21:28:42 +0000
commit5412b6f32e49d2319262c9413125ae11ec4b4544 (patch)
tree6e2e3b4b19a420e28e56e91bb3c1698a6d76257b /target/linux/ramips/patches-3.8/105-usb_dwc_otg.patch
parenta08646642eb3692b0a4a79d38b54dbbea00587d5 (diff)
downloadupstream-5412b6f32e49d2319262c9413125ae11ec4b4544.tar.gz
upstream-5412b6f32e49d2319262c9413125ae11ec4b4544.tar.bz2
upstream-5412b6f32e49d2319262c9413125ae11ec4b4544.zip
ramips: add support for 3.8
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 35801
Diffstat (limited to 'target/linux/ramips/patches-3.8/105-usb_dwc_otg.patch')
-rw-r--r--target/linux/ramips/patches-3.8/105-usb_dwc_otg.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/ramips/patches-3.8/105-usb_dwc_otg.patch b/target/linux/ramips/patches-3.8/105-usb_dwc_otg.patch
new file mode 100644
index 0000000000..88c211569b
--- /dev/null
+++ b/target/linux/ramips/patches-3.8/105-usb_dwc_otg.patch
@@ -0,0 +1,20 @@
+--- a/drivers/usb/Kconfig
++++ b/drivers/usb/Kconfig
+@@ -188,4 +188,6 @@ source "drivers/usb/gadget/Kconfig"
+
+ source "drivers/usb/otg/Kconfig"
+
++source "drivers/usb/dwc_otg/Kconfig"
++
+ endif # USB_SUPPORT
+--- a/drivers/usb/Makefile
++++ b/drivers/usb/Makefile
+@@ -52,6 +52,8 @@ obj-$(CONFIG_EARLY_PRINTK_DBGP) += early
+ obj-$(CONFIG_USB_ATM) += atm/
+ obj-$(CONFIG_USB_SPEEDTOUCH) += atm/
+
++obj-$(CONFIG_DWC_OTG) += dwc_otg/
++
+ obj-$(CONFIG_USB_MUSB_HDRC) += musb/
+ obj-$(CONFIG_USB_CHIPIDEA) += chipidea/
+ obj-$(CONFIG_USB_RENESAS_USBHS) += renesas_usbhs/