aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/patches-3.8/104-ramips-watchdog-driver.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-02-25 21:28:42 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-02-25 21:28:42 +0000
commit5412b6f32e49d2319262c9413125ae11ec4b4544 (patch)
tree6e2e3b4b19a420e28e56e91bb3c1698a6d76257b /target/linux/ramips/patches-3.8/104-ramips-watchdog-driver.patch
parenta08646642eb3692b0a4a79d38b54dbbea00587d5 (diff)
downloadupstream-5412b6f32e49d2319262c9413125ae11ec4b4544.tar.gz
upstream-5412b6f32e49d2319262c9413125ae11ec4b4544.tar.bz2
upstream-5412b6f32e49d2319262c9413125ae11ec4b4544.zip
ramips: add support for 3.8
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 35801
Diffstat (limited to 'target/linux/ramips/patches-3.8/104-ramips-watchdog-driver.patch')
-rw-r--r--target/linux/ramips/patches-3.8/104-ramips-watchdog-driver.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/ramips/patches-3.8/104-ramips-watchdog-driver.patch b/target/linux/ramips/patches-3.8/104-ramips-watchdog-driver.patch
new file mode 100644
index 0000000000..69ee00474b
--- /dev/null
+++ b/target/linux/ramips/patches-3.8/104-ramips-watchdog-driver.patch
@@ -0,0 +1,26 @@
+--- a/drivers/watchdog/Kconfig
++++ b/drivers/watchdog/Kconfig
+@@ -1076,6 +1076,13 @@ config LANTIQ_WDT
+ help
+ Hardware driver for the Lantiq SoC Watchdog Timer.
+
++config RAMIPS_WDT
++ tristate "Ralink RT288X/RT305X Watchdog Timer"
++ depends on (SOC_RT288X || SOC_RT305X || SOC_RT3883)
++ help
++ Hardware driver for the built-in watchdog timer on the
++ Ralink RT288X/RT305X SoCs.
++
+ # PARISC Architecture
+
+ # POWERPC Architecture
+--- a/drivers/watchdog/Makefile
++++ b/drivers/watchdog/Makefile
+@@ -132,6 +132,7 @@ obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
+ obj-$(CONFIG_OCTEON_WDT) += octeon-wdt.o
+ octeon-wdt-y := octeon-wdt-main.o octeon-wdt-nmi.o
+ obj-$(CONFIG_LANTIQ_WDT) += lantiq_wdt.o
++obj-$(CONFIG_RAMIPS_WDT) += ramips_wdt.o
+
+ # PARISC Architecture
+