aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/patches-3.7/105-usb_dwc_otg.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-12-22 12:11:13 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-12-22 12:11:13 +0000
commitb44cdcde8e9af4ac2cc4f94f11452a9c7d1f7dae (patch)
tree4088ff0bc830852ed01fd4cd47b3d4e85dfd29e9 /target/linux/ramips/patches-3.7/105-usb_dwc_otg.patch
parentfcf65bdee39b96757469988339d46bf89c26570d (diff)
downloadupstream-b44cdcde8e9af4ac2cc4f94f11452a9c7d1f7dae.tar.gz
upstream-b44cdcde8e9af4ac2cc4f94f11452a9c7d1f7dae.tar.bz2
upstream-b44cdcde8e9af4ac2cc4f94f11452a9c7d1f7dae.zip
ramips: add support for 3.7
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 34845
Diffstat (limited to 'target/linux/ramips/patches-3.7/105-usb_dwc_otg.patch')
-rw-r--r--target/linux/ramips/patches-3.7/105-usb_dwc_otg.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/ramips/patches-3.7/105-usb_dwc_otg.patch b/target/linux/ramips/patches-3.7/105-usb_dwc_otg.patch
new file mode 100644
index 0000000000..9f32893c66
--- /dev/null
+++ b/target/linux/ramips/patches-3.7/105-usb_dwc_otg.patch
@@ -0,0 +1,20 @@
+--- a/drivers/usb/Kconfig
++++ b/drivers/usb/Kconfig
+@@ -187,4 +187,6 @@ source "drivers/usb/gadget/Kconfig"
+
+ source "drivers/usb/otg/Kconfig"
+
++source "drivers/usb/dwc_otg/Kconfig"
++
+ endif # USB_SUPPORT
+--- a/drivers/usb/Makefile
++++ b/drivers/usb/Makefile
+@@ -52,6 +52,8 @@ obj-$(CONFIG_EARLY_PRINTK_DBGP) += early
+ obj-$(CONFIG_USB_ATM) += atm/
+ obj-$(CONFIG_USB_SPEEDTOUCH) += atm/
+
++obj-$(CONFIG_DWC_OTG) += dwc_otg/
++
+ obj-$(CONFIG_USB_MUSB_HDRC) += musb/
+ obj-$(CONFIG_USB_CHIPIDEA) += chipidea/
+ obj-$(CONFIG_USB_RENESAS_USBHS) += renesas_usbhs/