aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/patches-3.6/103-ethernet.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2012-11-07 20:25:34 +0000
committerJohn Crispin <john@openwrt.org>2012-11-07 20:25:34 +0000
commitca1fcaed5be02f18bf9c06473e3e554aa6801ab5 (patch)
tree1abe66efe47fe9848a14f92d7b49eb0babbb9ed6 /target/linux/ramips/patches-3.6/103-ethernet.patch
parentcc826486008092661ad72a57f3715948501a6f30 (diff)
downloadupstream-ca1fcaed5be02f18bf9c06473e3e554aa6801ab5.tar.gz
upstream-ca1fcaed5be02f18bf9c06473e3e554aa6801ab5.tar.bz2
upstream-ca1fcaed5be02f18bf9c06473e3e554aa6801ab5.zip
ramips: port patches to linux-3.6
Signed-off-by: Daniel Golle <dgolle@allnet.de> create mode 100644 target/linux/ramips/patches-3.6/001-mips-add-cp0-compare-irq-function.patch create mode 100644 target/linux/ramips/patches-3.6/010-mtd_fix_cfi_cmdset_0002_erase_status_check.patch create mode 100644 target/linux/ramips/patches-3.6/011-mtd-cfi_cmdset_0002-force-word-write.patch create mode 100644 target/linux/ramips/patches-3.6/100-mips-ralink-core.patch create mode 100644 target/linux/ramips/patches-3.6/101-rt288x_serial_driver_hack.patch create mode 100644 target/linux/ramips/patches-3.6/102-rt288x-pci-driver-hook.patch create mode 100644 target/linux/ramips/patches-3.6/103-ethernet.patch create mode 100644 target/linux/ramips/patches-3.6/104-ramips-watchdog-driver.patch create mode 100644 target/linux/ramips/patches-3.6/105-ramips-spi-driver.patch create mode 100644 target/linux/ramips/patches-3.6/105-usb_dwc_otg.patch create mode 100644 target/linux/ramips/patches-3.6/106-rt3883-pci-support.patch create mode 100644 target/linux/ramips/patches-3.6/200-rt3883-ehci-glue.patch create mode 100644 target/linux/ramips/patches-3.6/201-rt3883-ohci-glue.patch SVN-Revision: 34108
Diffstat (limited to 'target/linux/ramips/patches-3.6/103-ethernet.patch')
-rw-r--r--target/linux/ramips/patches-3.6/103-ethernet.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/ramips/patches-3.6/103-ethernet.patch b/target/linux/ramips/patches-3.6/103-ethernet.patch
new file mode 100644
index 0000000000..a3b402fb8e
--- /dev/null
+++ b/target/linux/ramips/patches-3.6/103-ethernet.patch
@@ -0,0 +1,20 @@
+--- a/drivers/net/ethernet/Kconfig
++++ b/drivers/net/ethernet/Kconfig
+@@ -145,6 +145,7 @@ source "drivers/net/ethernet/packetengin
+ source "drivers/net/ethernet/pasemi/Kconfig"
+ source "drivers/net/ethernet/qlogic/Kconfig"
+ source "drivers/net/ethernet/racal/Kconfig"
++source "drivers/net/ethernet/ramips/Kconfig"
+ source "drivers/net/ethernet/realtek/Kconfig"
+ source "drivers/net/ethernet/renesas/Kconfig"
+ source "drivers/net/ethernet/rdc/Kconfig"
+--- a/drivers/net/ethernet/Makefile
++++ b/drivers/net/ethernet/Makefile
+@@ -55,6 +55,7 @@ obj-$(CONFIG_NET_PACKET_ENGINE) += packe
+ obj-$(CONFIG_NET_VENDOR_PASEMI) += pasemi/
+ obj-$(CONFIG_NET_VENDOR_QLOGIC) += qlogic/
+ obj-$(CONFIG_NET_VENDOR_RACAL) += racal/
++obj-$(CONFIG_NET_RAMIPS) += ramips/
+ obj-$(CONFIG_NET_VENDOR_REALTEK) += realtek/
+ obj-$(CONFIG_SH_ETH) += renesas/
+ obj-$(CONFIG_NET_VENDOR_RDC) += rdc/