aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/patches-3.2/104-ramips-watchdog-driver.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-02-12 12:52:14 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-02-12 12:52:14 +0000
commit91cb3ccfdf2a34eb615273087fd153908a6454fb (patch)
treeb0d9cfa2222ca3cec3893bef7a5d6e9f10ce5e5e /target/linux/ramips/patches-3.2/104-ramips-watchdog-driver.patch
parenta01fc48535cb88833d77e31f4882f4547c9e2076 (diff)
downloadupstream-91cb3ccfdf2a34eb615273087fd153908a6454fb.tar.gz
upstream-91cb3ccfdf2a34eb615273087fd153908a6454fb.tar.bz2
upstream-91cb3ccfdf2a34eb615273087fd153908a6454fb.zip
ramips: add initial support for 3.2
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30476 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/patches-3.2/104-ramips-watchdog-driver.patch')
-rw-r--r--target/linux/ramips/patches-3.2/104-ramips-watchdog-driver.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/ramips/patches-3.2/104-ramips-watchdog-driver.patch b/target/linux/ramips/patches-3.2/104-ramips-watchdog-driver.patch
new file mode 100644
index 0000000000..293044dabd
--- /dev/null
+++ b/target/linux/ramips/patches-3.2/104-ramips-watchdog-driver.patch
@@ -0,0 +1,26 @@
+--- a/drivers/watchdog/Kconfig
++++ b/drivers/watchdog/Kconfig
+@@ -1020,6 +1020,13 @@ config LANTIQ_WDT
+ help
+ Hardware driver for the Lantiq SoC Watchdog Timer.
+
++config RAMIPS_WDT
++ tristate "Ralink RT288X/RT305X Watchdog Timer"
++ depends on SOC_RT288X || SOC_RT305X
++ help
++ Hardware driver for the built-in watchdog timer on the
++ Ralink RT288X/RT305X SoCs.
++
+ # PARISC Architecture
+
+ # POWERPC Architecture
+--- a/drivers/watchdog/Makefile
++++ b/drivers/watchdog/Makefile
+@@ -131,6 +131,7 @@ obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
+ obj-$(CONFIG_OCTEON_WDT) += octeon-wdt.o
+ octeon-wdt-y := octeon-wdt-main.o octeon-wdt-nmi.o
+ obj-$(CONFIG_LANTIQ_WDT) += lantiq_wdt.o
++obj-$(CONFIG_RAMIPS_WDT) += ramips_wdt.o
+
+ # PARISC Architecture
+