aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/patches-3.2/103-ethernet.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-02-12 12:52:14 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-02-12 12:52:14 +0000
commita287c60a61bbad21af22523ca50281850dd1e2c1 (patch)
tree96d48290c14dd4976311bb801c031b68285a74f2 /target/linux/ramips/patches-3.2/103-ethernet.patch
parent388013b0ce70c0cc7a40d031a8f94188f1214ad0 (diff)
downloadupstream-a287c60a61bbad21af22523ca50281850dd1e2c1.tar.gz
upstream-a287c60a61bbad21af22523ca50281850dd1e2c1.tar.bz2
upstream-a287c60a61bbad21af22523ca50281850dd1e2c1.zip
ramips: add initial support for 3.2
SVN-Revision: 30476
Diffstat (limited to 'target/linux/ramips/patches-3.2/103-ethernet.patch')
-rw-r--r--target/linux/ramips/patches-3.2/103-ethernet.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/ramips/patches-3.2/103-ethernet.patch b/target/linux/ramips/patches-3.2/103-ethernet.patch
new file mode 100644
index 0000000000..8953f3ba74
--- /dev/null
+++ b/target/linux/ramips/patches-3.2/103-ethernet.patch
@@ -0,0 +1,29 @@
+--- a/drivers/net/Kconfig
++++ b/drivers/net/Kconfig
+@@ -277,6 +277,16 @@ source "drivers/net/plip/Kconfig"
+
+ source "drivers/net/ppp/Kconfig"
+
++config MIPS_RAMIPS_NET
++ tristate "Ethernet driver for rt288x/rt305x"
++ depends on MIPS_RALINK
++ help
++ This driver supports the etehrnet mac inside the ralink wisocs
++
++config RAMIPS_ETH_DEBUG
++ bool "Enable debug messages in the Ralink ethernet driver"
++ depends on MIPS_RAMIPS_NET
++
+ source "drivers/net/slip/Kconfig"
+
+ source "drivers/s390/net/Kconfig"
+--- a/drivers/net/Makefile
++++ b/drivers/net/Makefile
+@@ -44,6 +44,7 @@ obj-$(CONFIG_PPP_SYNC_TTY) += ppp/
+ obj-$(CONFIG_PPPOE) += ppp/
+ obj-$(CONFIG_PPPOL2TP) += ppp/
+ obj-$(CONFIG_PPTP) += ppp/
++obj-$(CONFIG_MIPS_RAMIPS_NET) += ramips.o
+ obj-$(CONFIG_SLIP) += slip/
+ obj-$(CONFIG_SLHC) += slip/
+ obj-$(CONFIG_NET_SB1000) += sb1000.o