aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/patches-3.2/103-ethernet.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-02-12 12:52:14 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-02-12 12:52:14 +0000
commit91cb3ccfdf2a34eb615273087fd153908a6454fb (patch)
treeb0d9cfa2222ca3cec3893bef7a5d6e9f10ce5e5e /target/linux/ramips/patches-3.2/103-ethernet.patch
parenta01fc48535cb88833d77e31f4882f4547c9e2076 (diff)
downloadupstream-91cb3ccfdf2a34eb615273087fd153908a6454fb.tar.gz
upstream-91cb3ccfdf2a34eb615273087fd153908a6454fb.tar.bz2
upstream-91cb3ccfdf2a34eb615273087fd153908a6454fb.zip
ramips: add initial support for 3.2
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30476 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/patches-3.2/103-ethernet.patch')
-rw-r--r--target/linux/ramips/patches-3.2/103-ethernet.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/ramips/patches-3.2/103-ethernet.patch b/target/linux/ramips/patches-3.2/103-ethernet.patch
new file mode 100644
index 0000000000..8953f3ba74
--- /dev/null
+++ b/target/linux/ramips/patches-3.2/103-ethernet.patch
@@ -0,0 +1,29 @@
+--- a/drivers/net/Kconfig
++++ b/drivers/net/Kconfig
+@@ -277,6 +277,16 @@ source "drivers/net/plip/Kconfig"
+
+ source "drivers/net/ppp/Kconfig"
+
++config MIPS_RAMIPS_NET
++ tristate "Ethernet driver for rt288x/rt305x"
++ depends on MIPS_RALINK
++ help
++ This driver supports the etehrnet mac inside the ralink wisocs
++
++config RAMIPS_ETH_DEBUG
++ bool "Enable debug messages in the Ralink ethernet driver"
++ depends on MIPS_RAMIPS_NET
++
+ source "drivers/net/slip/Kconfig"
+
+ source "drivers/s390/net/Kconfig"
+--- a/drivers/net/Makefile
++++ b/drivers/net/Makefile
+@@ -44,6 +44,7 @@ obj-$(CONFIG_PPP_SYNC_TTY) += ppp/
+ obj-$(CONFIG_PPPOE) += ppp/
+ obj-$(CONFIG_PPPOL2TP) += ppp/
+ obj-$(CONFIG_PPTP) += ppp/
++obj-$(CONFIG_MIPS_RAMIPS_NET) += ramips.o
+ obj-$(CONFIG_SLIP) += slip/
+ obj-$(CONFIG_SLHC) += slip/
+ obj-$(CONFIG_NET_SB1000) += sb1000.o