aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/patches-3.18/0061-SPI-ralink-add-mt7621-SoC-spi-driver.patch
diff options
context:
space:
mode:
authorZoltan Herpai <wigyori@uid0.hu>2016-09-29 15:49:20 +0200
committerGitHub <noreply@github.com>2016-09-29 15:49:20 +0200
commitca3f1a614a1ee90fc67188b375888517f0c151df (patch)
tree930c456200793be1ec731e819aa0dd2e4b0b0dbf /target/linux/ramips/patches-3.18/0061-SPI-ralink-add-mt7621-SoC-spi-driver.patch
parentd6b3ca24c50047af58135ad3090f7a3a25eee35d (diff)
parentf9755e28776fdce0c2136492b43380d0eefe3c5a (diff)
downloadupstream-ca3f1a614a1ee90fc67188b375888517f0c151df.tar.gz
upstream-ca3f1a614a1ee90fc67188b375888517f0c151df.tar.bz2
upstream-ca3f1a614a1ee90fc67188b375888517f0c151df.zip
Merge pull request #105 from wigyori/chaos_calmer
CC: openssl security upgrade, sync updates from git.openwrt.org/chaos_calmer
Diffstat (limited to 'target/linux/ramips/patches-3.18/0061-SPI-ralink-add-mt7621-SoC-spi-driver.patch')
-rw-r--r--target/linux/ramips/patches-3.18/0061-SPI-ralink-add-mt7621-SoC-spi-driver.patch9
1 files changed, 6 insertions, 3 deletions
diff --git a/target/linux/ramips/patches-3.18/0061-SPI-ralink-add-mt7621-SoC-spi-driver.patch b/target/linux/ramips/patches-3.18/0061-SPI-ralink-add-mt7621-SoC-spi-driver.patch
index d52cd2e09d..4fe9f4c89e 100644
--- a/target/linux/ramips/patches-3.18/0061-SPI-ralink-add-mt7621-SoC-spi-driver.patch
+++ b/target/linux/ramips/patches-3.18/0061-SPI-ralink-add-mt7621-SoC-spi-driver.patch
@@ -1,6 +1,6 @@
--- a/drivers/spi/Kconfig
+++ b/drivers/spi/Kconfig
-@@ -439,6 +439,12 @@
+@@ -439,6 +439,12 @@ config SPI_RT2880
help
This selects a driver for the Ralink RT288x/RT305x SPI Controller.
@@ -15,7 +15,7 @@
depends on ARCH_S3C24XX
--- a/drivers/spi/Makefile
+++ b/drivers/spi/Makefile
-@@ -46,6 +46,7 @@
+@@ -46,6 +46,7 @@ obj-$(CONFIG_SPI_LM70_LLP) += spi-lm70l
obj-$(CONFIG_SPI_MPC512x_PSC) += spi-mpc512x-psc.o
obj-$(CONFIG_SPI_MPC52xx_PSC) += spi-mpc52xx-psc.o
obj-$(CONFIG_SPI_MPC52xx) += spi-mpc52xx.o
@@ -25,7 +25,7 @@
obj-$(CONFIG_SPI_OC_TINY) += spi-oc-tiny.o
--- /dev/null
+++ b/drivers/spi/spi-mt7621.c
-@@ -0,0 +1,391 @@
+@@ -0,0 +1,394 @@
+/*
+ * spi-mt7621.c -- MediaTek MT7621 SPI controller driver
+ *
@@ -225,6 +225,9 @@
+ if (!buf)
+ continue;
+
++ if (t->speed_hz < speed)
++ speed = t->speed_hz;
++
+ if (WARN_ON(len + rlen > 36)) {
+ status = -EIO;
+ goto msg_done;