aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/patches-3.10/0505-watchdog-add-MT7621-support.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2014-01-11 16:06:37 +0000
committerGabor Juhos <juhosg@openwrt.org>2014-01-11 16:06:37 +0000
commitd3305e8570dba327c25bc62584e2874fbb3d2008 (patch)
tree6466a8c5f3d798497135e9e56cdc24fbd941602e /target/linux/ramips/patches-3.10/0505-watchdog-add-MT7621-support.patch
parent95b66c31118df52b4417fe2e070cbe75aa7d8ade (diff)
downloadupstream-d3305e8570dba327c25bc62584e2874fbb3d2008.tar.gz
upstream-d3305e8570dba327c25bc62584e2874fbb3d2008.tar.bz2
upstream-d3305e8570dba327c25bc62584e2874fbb3d2008.zip
kernel: update 3.10 to 3.10.26
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39220 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/patches-3.10/0505-watchdog-add-MT7621-support.patch')
-rw-r--r--target/linux/ramips/patches-3.10/0505-watchdog-add-MT7621-support.patch22
1 files changed, 8 insertions, 14 deletions
diff --git a/target/linux/ramips/patches-3.10/0505-watchdog-add-MT7621-support.patch b/target/linux/ramips/patches-3.10/0505-watchdog-add-MT7621-support.patch
index af02f92e25..b1d2da7766 100644
--- a/target/linux/ramips/patches-3.10/0505-watchdog-add-MT7621-support.patch
+++ b/target/linux/ramips/patches-3.10/0505-watchdog-add-MT7621-support.patch
@@ -11,11 +11,9 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
3 files changed, 193 insertions(+)
create mode 100644 drivers/watchdog/mt7621_wdt.c
-Index: linux-3.10.21/drivers/watchdog/Kconfig
-===================================================================
---- linux-3.10.21.orig/drivers/watchdog/Kconfig 2013-12-09 19:56:09.360682007 +0100
-+++ linux-3.10.21/drivers/watchdog/Kconfig 2013-12-09 19:59:20.636686594 +0100
-@@ -1116,7 +1116,14 @@
+--- a/drivers/watchdog/Kconfig
++++ b/drivers/watchdog/Kconfig
+@@ -1116,7 +1116,14 @@ config LANTIQ_WDT
config RALINK_WDT
tristate "Ralink SoC watchdog"
select WATCHDOG_CORE
@@ -31,11 +29,9 @@ Index: linux-3.10.21/drivers/watchdog/Kconfig
help
Hardware driver for the Ralink SoC Watchdog Timer.
-Index: linux-3.10.21/drivers/watchdog/Makefile
-===================================================================
---- linux-3.10.21.orig/drivers/watchdog/Makefile 2013-12-09 19:56:09.360682007 +0100
-+++ linux-3.10.21/drivers/watchdog/Makefile 2013-12-09 19:56:09.752682016 +0100
-@@ -136,6 +136,7 @@
+--- a/drivers/watchdog/Makefile
++++ b/drivers/watchdog/Makefile
+@@ -136,6 +136,7 @@ obj-$(CONFIG_OCTEON_WDT) += octeon-wdt.o
octeon-wdt-y := octeon-wdt-main.o octeon-wdt-nmi.o
obj-$(CONFIG_LANTIQ_WDT) += lantiq_wdt.o
obj-$(CONFIG_RALINK_WDT) += rt2880_wdt.o
@@ -43,10 +39,8 @@ Index: linux-3.10.21/drivers/watchdog/Makefile
# PARISC Architecture
-Index: linux-3.10.21/drivers/watchdog/mt7621_wdt.c
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.10.21/drivers/watchdog/mt7621_wdt.c 2013-12-09 19:56:09.752682016 +0100
+--- /dev/null
++++ b/drivers/watchdog/mt7621_wdt.c
@@ -0,0 +1,185 @@
+/*
+ * Ralink RT288x/RT3xxx/MT76xx built-in hardware watchdog timer