aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/patches-3.10/0019-USB-add-OHCI-EHCI-OF-binding.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-07-22 15:31:13 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-07-22 15:31:13 +0000
commitef944dcb85dea57bdc4b42b8b6fcecacf00b2e92 (patch)
tree111f67b615233af594bc5e29460af254bf85274e /target/linux/ramips/patches-3.10/0019-USB-add-OHCI-EHCI-OF-binding.patch
parent6a5b4ec7dc2abeecd47345e2fb5aeb83ea50f322 (diff)
downloadupstream-ef944dcb85dea57bdc4b42b8b6fcecacf00b2e92.tar.gz
upstream-ef944dcb85dea57bdc4b42b8b6fcecacf00b2e92.tar.bz2
upstream-ef944dcb85dea57bdc4b42b8b6fcecacf00b2e92.zip
kernel: update 3.10 to 3.10.2
Also refresh 3.10 patches. Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 37502
Diffstat (limited to 'target/linux/ramips/patches-3.10/0019-USB-add-OHCI-EHCI-OF-binding.patch')
-rw-r--r--target/linux/ramips/patches-3.10/0019-USB-add-OHCI-EHCI-OF-binding.patch48
1 files changed, 20 insertions, 28 deletions
diff --git a/target/linux/ramips/patches-3.10/0019-USB-add-OHCI-EHCI-OF-binding.patch b/target/linux/ramips/patches-3.10/0019-USB-add-OHCI-EHCI-OF-binding.patch
index e442f2f2a2..14da4ae816 100644
--- a/target/linux/ramips/patches-3.10/0019-USB-add-OHCI-EHCI-OF-binding.patch
+++ b/target/linux/ramips/patches-3.10/0019-USB-add-OHCI-EHCI-OF-binding.patch
@@ -13,11 +13,9 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
drivers/usb/host/ohci-platform.c | 37 ++++++++++++++++++++++++++++++++-----
4 files changed, 51 insertions(+), 10 deletions(-)
-Index: linux-3.10.1/arch/mips/ralink/Kconfig
-===================================================================
---- linux-3.10.1.orig/arch/mips/ralink/Kconfig 2013-07-15 17:35:28.021178556 +0200
-+++ linux-3.10.1/arch/mips/ralink/Kconfig 2013-07-15 20:00:19.501385660 +0200
-@@ -24,6 +24,8 @@
+--- a/arch/mips/ralink/Kconfig
++++ b/arch/mips/ralink/Kconfig
+@@ -24,6 +24,8 @@ choice
config SOC_MT7620
bool "MT7620"
@@ -26,11 +24,9 @@ Index: linux-3.10.1/arch/mips/ralink/Kconfig
select HW_HAS_PCI
endchoice
-Index: linux-3.10.1/drivers/usb/Makefile
-===================================================================
---- linux-3.10.1.orig/drivers/usb/Makefile 2013-07-13 20:42:41.000000000 +0200
-+++ linux-3.10.1/drivers/usb/Makefile 2013-07-15 19:47:26.725367249 +0200
-@@ -10,6 +10,8 @@
+--- a/drivers/usb/Makefile
++++ b/drivers/usb/Makefile
+@@ -10,6 +10,8 @@ obj-$(CONFIG_USB_DWC3) += dwc3/
obj-$(CONFIG_USB_MON) += mon/
@@ -39,7 +35,7 @@ Index: linux-3.10.1/drivers/usb/Makefile
obj-$(CONFIG_PCI) += host/
obj-$(CONFIG_USB_EHCI_HCD) += host/
obj-$(CONFIG_USB_ISP116X_HCD) += host/
-@@ -44,7 +46,6 @@
+@@ -44,7 +46,6 @@ obj-$(CONFIG_USB_MICROTEK) += image/
obj-$(CONFIG_USB_SERIAL) += serial/
obj-$(CONFIG_USB) += misc/
@@ -47,10 +43,8 @@ Index: linux-3.10.1/drivers/usb/Makefile
obj-$(CONFIG_EARLY_PRINTK_DBGP) += early/
obj-$(CONFIG_USB_ATM) += atm/
-Index: linux-3.10.1/drivers/usb/host/ehci-platform.c
-===================================================================
---- linux-3.10.1.orig/drivers/usb/host/ehci-platform.c 2013-07-15 17:35:22.761178428 +0200
-+++ linux-3.10.1/drivers/usb/host/ehci-platform.c 2013-07-15 19:47:14.525366961 +0200
+--- a/drivers/usb/host/ehci-platform.c
++++ b/drivers/usb/host/ehci-platform.c
@@ -29,6 +29,8 @@
#include <linux/usb.h>
#include <linux/usb/hcd.h>
@@ -60,7 +54,7 @@ Index: linux-3.10.1/drivers/usb/host/ehci-platform.c
#include "ehci.h"
-@@ -118,6 +120,15 @@
+@@ -118,6 +120,15 @@ static int ehci_platform_probe(struct pl
hcd->rsrc_start = res_mem->start;
hcd->rsrc_len = resource_size(res_mem);
@@ -76,7 +70,7 @@ Index: linux-3.10.1/drivers/usb/host/ehci-platform.c
hcd->regs = devm_ioremap_resource(&dev->dev, res_mem);
if (IS_ERR(hcd->regs)) {
err = PTR_ERR(hcd->regs);
-@@ -155,6 +166,9 @@
+@@ -155,6 +166,9 @@ static int ehci_platform_remove(struct p
if (pdata == &ehci_platform_defaults)
dev->dev.platform_data = NULL;
@@ -86,7 +80,7 @@ Index: linux-3.10.1/drivers/usb/host/ehci-platform.c
return 0;
}
-@@ -199,9 +213,8 @@
+@@ -199,9 +213,8 @@ static int ehci_platform_resume(struct d
#define ehci_platform_resume NULL
#endif /* CONFIG_PM */
@@ -98,7 +92,7 @@ Index: linux-3.10.1/drivers/usb/host/ehci-platform.c
{}
};
-@@ -225,7 +238,7 @@
+@@ -225,7 +238,7 @@ static struct platform_driver ehci_platf
.owner = THIS_MODULE,
.name = "ehci-platform",
.pm = &ehci_platform_pm_ops,
@@ -107,10 +101,8 @@ Index: linux-3.10.1/drivers/usb/host/ehci-platform.c
}
};
-Index: linux-3.10.1/drivers/usb/host/ohci-platform.c
-===================================================================
---- linux-3.10.1.orig/drivers/usb/host/ohci-platform.c 2013-07-13 20:42:41.000000000 +0200
-+++ linux-3.10.1/drivers/usb/host/ohci-platform.c 2013-07-15 19:55:15.913378428 +0200
+--- a/drivers/usb/host/ohci-platform.c
++++ b/drivers/usb/host/ohci-platform.c
@@ -16,6 +16,10 @@
#include <linux/err.h>
#include <linux/platform_device.h>
@@ -122,7 +114,7 @@ Index: linux-3.10.1/drivers/usb/host/ohci-platform.c
static int ohci_platform_reset(struct usb_hcd *hcd)
{
-@@ -88,14 +92,22 @@
+@@ -88,14 +92,22 @@ static int ohci_platform_probe(struct pl
{
struct usb_hcd *hcd;
struct resource *res_mem;
@@ -150,7 +142,7 @@ Index: linux-3.10.1/drivers/usb/host/ohci-platform.c
if (usb_disabled())
return -ENODEV;
-@@ -128,6 +140,12 @@
+@@ -128,6 +140,12 @@ static int ohci_platform_probe(struct pl
hcd->rsrc_start = res_mem->start;
hcd->rsrc_len = resource_size(res_mem);
@@ -163,7 +155,7 @@ Index: linux-3.10.1/drivers/usb/host/ohci-platform.c
hcd->regs = devm_ioremap_resource(&dev->dev, res_mem);
if (IS_ERR(hcd->regs)) {
err = PTR_ERR(hcd->regs);
-@@ -162,6 +180,9 @@
+@@ -162,6 +180,9 @@ static int ohci_platform_remove(struct p
if (pdata->power_off)
pdata->power_off(dev);
@@ -173,7 +165,7 @@ Index: linux-3.10.1/drivers/usb/host/ohci-platform.c
return 0;
}
-@@ -201,6 +222,11 @@
+@@ -201,6 +222,11 @@ static int ohci_platform_resume(struct d
#define ohci_platform_resume NULL
#endif /* CONFIG_PM */
@@ -185,7 +177,7 @@ Index: linux-3.10.1/drivers/usb/host/ohci-platform.c
static const struct platform_device_id ohci_platform_table[] = {
{ "ohci-platform", 0 },
{ }
-@@ -221,5 +247,6 @@
+@@ -221,5 +247,6 @@ static struct platform_driver ohci_platf
.owner = THIS_MODULE,
.name = "ohci-platform",
.pm = &ohci_platform_pm_ops,