aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/patches-2.6.39/103-ethernet.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2011-07-03 15:02:06 +0000
committerGabor Juhos <juhosg@openwrt.org>2011-07-03 15:02:06 +0000
commit0fde070cf96233b124204a0e061897270b060e4c (patch)
tree8c1f10a682895d2d881e4e3e91312dbaace6cc6d /target/linux/ramips/patches-2.6.39/103-ethernet.patch
parent1c96bc9abc83c9260788631829060fcb1dabc877 (diff)
downloadupstream-0fde070cf96233b124204a0e061897270b060e4c.tar.gz
upstream-0fde070cf96233b124204a0e061897270b060e4c.tar.bz2
upstream-0fde070cf96233b124204a0e061897270b060e4c.zip
ramips: add 2.6.39 support
Based on the patches from #9625 SVN-Revision: 27396
Diffstat (limited to 'target/linux/ramips/patches-2.6.39/103-ethernet.patch')
-rw-r--r--target/linux/ramips/patches-2.6.39/103-ethernet.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/ramips/patches-2.6.39/103-ethernet.patch b/target/linux/ramips/patches-2.6.39/103-ethernet.patch
new file mode 100644
index 0000000000..2b02b49187
--- /dev/null
+++ b/target/linux/ramips/patches-2.6.39/103-ethernet.patch
@@ -0,0 +1,25 @@
+--- a/drivers/net/Kconfig
++++ b/drivers/net/Kconfig
+@@ -494,6 +494,12 @@ config MIPS_AU1X00_ENET
+ If you have an Alchemy Semi AU1X00 based system
+ say Y. Otherwise, say N.
+
++config MIPS_RAMIPS_NET
++ tristate "Ethernet driver for rt288x/rt305x"
++ depends on MIPS_RALINK
++ help
++ This driver supports the etehrnet mac inside the ralink wisocs
++
+ config SGI_IOC3_ETH
+ bool "SGI IOC3 Ethernet"
+ depends on PCI && SGI_IP27
+--- a/drivers/net/Makefile
++++ b/drivers/net/Makefile
+@@ -227,6 +227,7 @@ obj-$(CONFIG_KORINA) += korina.o
+ obj-$(CONFIG_MIPS_JAZZ_SONIC) += jazzsonic.o
+ obj-$(CONFIG_MIPS_AU1X00_ENET) += au1000_eth.o
+ obj-$(CONFIG_MIPS_SIM_NET) += mipsnet.o
++obj-$(CONFIG_MIPS_RAMIPS_NET) += ramips.o
+ obj-$(CONFIG_SGI_IOC3_ETH) += ioc3-eth.o
+ obj-$(CONFIG_DECLANCE) += declance.o
+ obj-$(CONFIG_ATARILANCE) += atarilance.o