aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/patches-2.6.37/104-ramips-watchdog-driver.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2011-03-27 19:20:04 +0000
committerGabor Juhos <juhosg@openwrt.org>2011-03-27 19:20:04 +0000
commit90d37adb8dddd457b5fa7fc9887bb76d61e53549 (patch)
tree659f34b58bc34309950a6fe7320e508e61f5b6e5 /target/linux/ramips/patches-2.6.37/104-ramips-watchdog-driver.patch
parent1844ea6c7b5f8ef8892d825637d7eddf25391c55 (diff)
downloadupstream-90d37adb8dddd457b5fa7fc9887bb76d61e53549.tar.gz
upstream-90d37adb8dddd457b5fa7fc9887bb76d61e53549.tar.bz2
upstream-90d37adb8dddd457b5fa7fc9887bb76d61e53549.zip
ramips: switch to 2.6.37
SVN-Revision: 26328
Diffstat (limited to 'target/linux/ramips/patches-2.6.37/104-ramips-watchdog-driver.patch')
-rw-r--r--target/linux/ramips/patches-2.6.37/104-ramips-watchdog-driver.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/ramips/patches-2.6.37/104-ramips-watchdog-driver.patch b/target/linux/ramips/patches-2.6.37/104-ramips-watchdog-driver.patch
new file mode 100644
index 0000000000..643a6a0b66
--- /dev/null
+++ b/target/linux/ramips/patches-2.6.37/104-ramips-watchdog-driver.patch
@@ -0,0 +1,26 @@
+--- a/drivers/watchdog/Kconfig
++++ b/drivers/watchdog/Kconfig
+@@ -930,6 +930,13 @@ config BCM63XX_WDT
+ To compile this driver as a loadable module, choose M here.
+ The module will be called bcm63xx_wdt.
+
++config RAMIPS_WDT
++ tristate "Ralink RT288X/RT305X Watchdog Timer"
++ depends on SOC_RT288X || SOC_RT305X
++ help
++ Hardware driver for the built-in watchdog timer on the
++ Ralink RT288X/RT305X SoCs.
++
+ # PARISC Architecture
+
+ # POWERPC Architecture
+--- a/drivers/watchdog/Makefile
++++ b/drivers/watchdog/Makefile
+@@ -119,6 +119,7 @@ obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
+ obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
+ obj-$(CONFIG_OCTEON_WDT) += octeon-wdt.o
+ octeon-wdt-y := octeon-wdt-main.o octeon-wdt-nmi.o
++obj-$(CONFIG_RAMIPS_WDT) += ramips_wdt.o
+
+ # PARISC Architecture
+