aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/patches-2.6.36/104-ramips-watchdog-driver.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2011-01-26 20:48:41 +0000
committerGabor Juhos <juhosg@openwrt.org>2011-01-26 20:48:41 +0000
commit16366feafb3e5df1878d2651ab8bffbec2cca7bc (patch)
tree07907407a7f4871d45ad8d98fe8eee8d6659bd32 /target/linux/ramips/patches-2.6.36/104-ramips-watchdog-driver.patch
parentf38367fcb4fe2102c45f21101aac986efa7736c7 (diff)
downloadupstream-16366feafb3e5df1878d2651ab8bffbec2cca7bc.tar.gz
upstream-16366feafb3e5df1878d2651ab8bffbec2cca7bc.tar.bz2
upstream-16366feafb3e5df1878d2651ab8bffbec2cca7bc.zip
ramips: add watchdog driver
SVN-Revision: 25126
Diffstat (limited to 'target/linux/ramips/patches-2.6.36/104-ramips-watchdog-driver.patch')
-rw-r--r--target/linux/ramips/patches-2.6.36/104-ramips-watchdog-driver.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/ramips/patches-2.6.36/104-ramips-watchdog-driver.patch b/target/linux/ramips/patches-2.6.36/104-ramips-watchdog-driver.patch
new file mode 100644
index 0000000000..17bb376895
--- /dev/null
+++ b/target/linux/ramips/patches-2.6.36/104-ramips-watchdog-driver.patch
@@ -0,0 +1,26 @@
+--- a/drivers/watchdog/Kconfig
++++ b/drivers/watchdog/Kconfig
+@@ -916,6 +916,13 @@ config OCTEON_WDT
+ from the first interrupt, it is then only poked when the
+ device is written.
+
++config RAMIPS_WDT
++ tristate "Ralink RT288X/RT305X Watchdog Timer"
++ depends on SOC_RT288X || SOC_RT305X
++ help
++ Hardware driver for the built-in watchdog timer on the
++ Ralink RT288X/RT305X SoCs.
++
+ # PARISC Architecture
+
+ # POWERPC Architecture
+--- a/drivers/watchdog/Makefile
++++ b/drivers/watchdog/Makefile
+@@ -118,6 +118,7 @@ obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
+ obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
+ obj-$(CONFIG_OCTEON_WDT) += octeon-wdt.o
+ octeon-wdt-y := octeon-wdt-main.o octeon-wdt-nmi.o
++obj-$(CONFIG_RAMIPS_WDT) += ramips_wdt.o
+
+ # PARISC Architecture
+