aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/mt76x8/profiles
diff options
context:
space:
mode:
authorL. D. Pinney <ldpinney@gmail.com>2017-08-26 09:49:45 +0800
committerJohn Crispin <john@phrozen.org>2017-08-30 17:05:10 +0200
commit3e36ca4b436510a6e411484db47f7df35ebaf86d (patch)
tree4da1aa1d6c869a299512988328a678c99c97d63e /target/linux/ramips/mt76x8/profiles
parent40213cc15469fe5953e3d586ecb5870a382ee1ea (diff)
downloadupstream-3e36ca4b436510a6e411484db47f7df35ebaf86d.tar.gz
upstream-3e36ca4b436510a6e411484db47f7df35ebaf86d.tar.bz2
upstream-3e36ca4b436510a6e411484db47f7df35ebaf86d.zip
ramips: merge mt7628/mt7688 into mt76x8
The ramips subtargets of mt7628 and mt7688 dts files all #include "mt7628an.dtsi" They are essentially a single subtarget. This patch merges the ramips subtargets mt7628 and mt7688 into a single subtarget mt76x8. Signed-off-by: L. D. Pinney <ldpinney@gmail.com>
Diffstat (limited to 'target/linux/ramips/mt76x8/profiles')
-rw-r--r--target/linux/ramips/mt76x8/profiles/00-default.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/ramips/mt76x8/profiles/00-default.mk b/target/linux/ramips/mt76x8/profiles/00-default.mk
new file mode 100644
index 0000000000..162ac14315
--- /dev/null
+++ b/target/linux/ramips/mt76x8/profiles/00-default.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+ NAME:=Default Profile
+ PRIORITY:=1
+ PACKAGES:= kmod-usb-core kmod-usb2 kmod-usb-ohci kmod-usb-ledtrig-usbport
+endef
+
+define Profile/Default/Description
+ Default package set compatible with most boards.
+endef
+$(eval $(call Profile,Default))