aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/mt7688
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-10-19 10:19:22 +0000
committerJohn Crispin <blogic@openwrt.org>2015-10-19 10:19:22 +0000
commitebff32ce9e793005ff6a54037bf02ea067a41569 (patch)
tree4d65207171a171f6bcc6cf814537b9baa6f3103a /target/linux/ramips/mt7688
parent563f3a4cb7cdc56f3134144bdd59e24adcdd5e21 (diff)
downloadupstream-ebff32ce9e793005ff6a54037bf02ea067a41569.tar.gz
upstream-ebff32ce9e793005ff6a54037bf02ea067a41569.tar.bz2
upstream-ebff32ce9e793005ff6a54037bf02ea067a41569.zip
ramips: add LinkIt Smart7688 support
Signed-off-by: John Crispin <blogic@openwrt.org> Backport of r47203 git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@47227 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/mt7688')
-rw-r--r--target/linux/ramips/mt7688/profiles/01-mediatek.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/ramips/mt7688/profiles/01-mediatek.mk b/target/linux/ramips/mt7688/profiles/01-mediatek.mk
new file mode 100644
index 0000000000..4ba838fb92
--- /dev/null
+++ b/target/linux/ramips/mt7688/profiles/01-mediatek.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/LinkIt7688
+ NAME:=LinkIt7688
+ PACKAGES:=\
+ kmod-usb-core kmod-usb2 kmod-usb-ohci \
+ uboot-envtools kmod-ledtrig-netdev
+endef
+
+define Profile/LinkIt7688/Description
+ Default package set compatible with most boards.
+endef
+$(eval $(call Profile,LinkIt7688))