aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/mt7621/profiles/storylink.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-08-17 06:01:38 +0000
committerJohn Crispin <john@openwrt.org>2015-08-17 06:01:38 +0000
commit57e614c1790e316ef8b5b8cb0cd4ae4dcb185d3d (patch)
treef79dc5fd960c594a010ad7b296f13b44e6c77847 /target/linux/ramips/mt7621/profiles/storylink.mk
parent0d464c360f0de4d90c8b25b2b2960ac7b5392cae (diff)
downloadupstream-57e614c1790e316ef8b5b8cb0cd4ae4dcb185d3d.tar.gz
upstream-57e614c1790e316ef8b5b8cb0cd4ae4dcb185d3d.tar.bz2
upstream-57e614c1790e316ef8b5b8cb0cd4ae4dcb185d3d.zip
ramips: fix various mistakes in subtargets *.mk profiles
This patch: * fixes wrong indentation * fixes wrong names and descriptions (ex. Dlink -> D-Link) * changes filenames to manufacturer names * moves oem/unknown manufacturers boards to misc.mk profiles * combines profiles for boards from the same manufacturers in one file (ex. Olimex) * fix profile files structure (keep the same convention as in other targets, ex. ar71xx) in various .mk profiles, in ramips target. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com> SVN-Revision: 46631
Diffstat (limited to 'target/linux/ramips/mt7621/profiles/storylink.mk')
-rw-r--r--target/linux/ramips/mt7621/profiles/storylink.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/ramips/mt7621/profiles/storylink.mk b/target/linux/ramips/mt7621/profiles/storylink.mk
new file mode 100644
index 0000000000..9ca4a2f743
--- /dev/null
+++ b/target/linux/ramips/mt7621/profiles/storylink.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/SAP-G3200U3
+ NAME:=STORYLiNK SAP-G3200U3
+ PACKAGES:=\
+ kmod-usb-core kmod-usb3 kmod-usb-hid \
+ kmod-ledtrig-usbdev
+endef
+
+define Profile/SAP-G3200U3/Description
+ Package set compatible with the STORYLiNK SAP-G3200U3 board.
+endef
+$(eval $(call Profile,SAP-G3200U3))