aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/mt7621/profiles/pbr-m1.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-06-18 20:24:05 +0000
committerJohn Crispin <blogic@openwrt.org>2015-06-18 20:24:05 +0000
commit33343146d54a76b20b2fad8a77ad0738ab355b27 (patch)
treede1d0678530013a49b075be8f2bc855a3e648a0d /target/linux/ramips/mt7621/profiles/pbr-m1.mk
parent48a944c9cb79c4819a9a54b4ba6d172f91f9ef27 (diff)
downloadupstream-33343146d54a76b20b2fad8a77ad0738ab355b27.tar.gz
upstream-33343146d54a76b20b2fad8a77ad0738ab355b27.tar.bz2
upstream-33343146d54a76b20b2fad8a77ad0738ab355b27.zip
ramips: add support for PandoraBox PBR-M1
This patch is for PandoraBox PBR-M1 which is based on mt7621, all the features work fine, including rtc, leds, button, usb3.0, etc. Signed-off-by: tymon <banglang.huang@foxmail.com> Backport of r46041 git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@46051 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/mt7621/profiles/pbr-m1.mk')
-rw-r--r--target/linux/ramips/mt7621/profiles/pbr-m1.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/ramips/mt7621/profiles/pbr-m1.mk b/target/linux/ramips/mt7621/profiles/pbr-m1.mk
new file mode 100644
index 0000000000..5b4dfb58cf
--- /dev/null
+++ b/target/linux/ramips/mt7621/profiles/pbr-m1.mk
@@ -0,0 +1,22 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/PBR-M1
+ NAME:=PBR-M1 Device
+ PACKAGES:=\
+ kmod-usb-core kmod-usb3 kmod-usb-hid kmod-sdhci-mt7620 \
+ kmod-ledtrig-usbdev kmod-mt76 kmod-ata-core kmod-ata-ahci \
+ kmod-usb3-mt7621 kmod-rtc-pcf8563
+endef
+
+
+FEATURES+=rtc
+
+define Profile/PBR-M1/Description
+ Default package set compatible with most boards.
+endef
+$(eval $(call Profile,PBR-M1))