aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/mt7620
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-02-26 07:46:18 +0000
committerJohn Crispin <blogic@openwrt.org>2016-02-26 07:46:18 +0000
commit43869ba1b27ba99da612e6afc0a7c7a3f30fec1a (patch)
treeaa04916f99388cc150046880d21fe771de71559a /target/linux/ramips/mt7620
parentba0f149034e82b4c63eecf95e5d4ab762ff0325a (diff)
downloadupstream-43869ba1b27ba99da612e6afc0a7c7a3f30fec1a.tar.gz
upstream-43869ba1b27ba99da612e6afc0a7c7a3f30fec1a.tar.bz2
upstream-43869ba1b27ba99da612e6afc0a7c7a3f30fec1a.zip
ramips: Backport support for Netgear EX2700
This patch adds support for the Netgear EX2700 in Chaos Calmer and builds approriate -sysupgrade and -factory images. Signed-off-by: Joseph C. Lehner <joseph.c.lehner@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@48792 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/mt7620')
-rw-r--r--target/linux/ramips/mt7620/profiles/netgear.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ramips/mt7620/profiles/netgear.mk b/target/linux/ramips/mt7620/profiles/netgear.mk
new file mode 100644
index 0000000000..d1b073abc2
--- /dev/null
+++ b/target/linux/ramips/mt7620/profiles/netgear.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/EX2700
+ NAME:=Netgear EX2700
+ PACKAGES:=-kmod-usb-core -kmod-usb2 -kmod-usb-ohci -kmod-ledtrig-usbdev
+endef
+
+define Profile/EX2700/Description
+ Support for Netgear EX2700
+endef
+$(eval $(call Profile,EX2700))