aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/modules.mk
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2020-03-05 23:42:18 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-03-13 15:40:43 +0100
commit4caaa778f709a38c08a11d98dd7fb03fe257f8fe (patch)
tree9e7858ea623824c7c2d5c2782d655488c5b2c7da /target/linux/ramips/modules.mk
parent4159054fbbf8a7176eaf3dd4467c5b0db70769d0 (diff)
downloadupstream-4caaa778f709a38c08a11d98dd7fb03fe257f8fe.tar.gz
upstream-4caaa778f709a38c08a11d98dd7fb03fe257f8fe.tar.bz2
upstream-4caaa778f709a38c08a11d98dd7fb03fe257f8fe.zip
kernel: make kmod-i2c-core selected by dependent modules
Currently kmod-i2c-* will not get into images unless kmod-i2c-core is added to DEVICE_PACKAGES as well. By changing the dependencies from "depends on" to "select", we do not have the issue anymore. Furthermore, we can remove most occurrences of the package from DEVICE_PACKAGES and similar variables, as it is now pulled by dependent modules such as: - kmod-hwmon-lm75 - kmod-i2c-gpio - kmod-i2c-gpio-custom - kmod-i2c-mux - kmod-i2c-ralink Signed-off-by: Sungbo Eo <mans0n@gorani.run> [do not touch ar71xx] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ramips/modules.mk')
-rw-r--r--target/linux/ramips/modules.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/ramips/modules.mk b/target/linux/ramips/modules.mk
index 89bdc6c95c..1ce914439c 100644
--- a/target/linux/ramips/modules.mk
+++ b/target/linux/ramips/modules.mk
@@ -47,7 +47,7 @@ I2C_RALINK_MODULES:= \
define KernelPackage/i2c-ralink
$(call i2c_defaults,$(I2C_RALINK_MODULES),59)
TITLE:=Ralink I2C Controller
- DEPENDS:=kmod-i2c-core @TARGET_ramips \
+ DEPENDS:=+kmod-i2c-core @TARGET_ramips \
@!(TARGET_ramips_mt7621||TARGET_ramips_mt76x8)
endef
@@ -64,7 +64,7 @@ I2C_MT7621_MODULES:= \
define KernelPackage/i2c-mt7628
$(call i2c_defaults,$(I2C_MT7621_MODULES),59)
TITLE:=MT7628/88 I2C Controller
- DEPENDS:=kmod-i2c-core \
+ DEPENDS:=+kmod-i2c-core \
@(TARGET_ramips_mt76x8)
endef