aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/modules.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2016-06-14 14:31:15 +0200
committerJo-Philipp Wich <jo@mein.io>2016-06-14 14:31:18 +0200
commit5550d98015f825cd60001cfcd7a31e8655e1cbeb (patch)
tree583f2cbe3718394d74f2d7202dc8335689238af9 /target/linux/ramips/modules.mk
parent489efcfd625e01b4a20bdf0901d20776df484135 (diff)
downloadupstream-5550d98015f825cd60001cfcd7a31e8655e1cbeb.tar.gz
upstream-5550d98015f825cd60001cfcd7a31e8655e1cbeb.tar.bz2
upstream-5550d98015f825cd60001cfcd7a31e8655e1cbeb.zip
ramips: fix kmod-sound-mt7620 packaging
Commit 9ff8928bb9c28be701eb963e591afcfd54b9d8c9 renamed the snd-soc-mt7620-i2s driver and dropped snd-soc-mt7620-wm8960 which selected CONFIG_SND_SOC_WM8960 breaking all ramips builds due to undefined kernel config symbols. Rework the kmod-sound-mt7620 package to explicitely select the CONFIG_SND_SOC_WM8960 symbols and change it to bundle the renamed .ko file. Also remove the @BROKEN flag and exclude it on the rt288x subtarget instead. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'target/linux/ramips/modules.mk')
-rw-r--r--target/linux/ramips/modules.mk11
1 files changed, 5 insertions, 6 deletions
diff --git a/target/linux/ramips/modules.mk b/target/linux/ramips/modules.mk
index 15017d01d9..370d0ccfdc 100644
--- a/target/linux/ramips/modules.mk
+++ b/target/linux/ramips/modules.mk
@@ -76,15 +76,14 @@ $(eval $(call KernelPackage,i2c-mt7621))
define KernelPackage/sound-mt7620
TITLE:=MT7620 PCM/I2S Alsa Driver
- DEPENDS:=@TARGET_ramips_mt7620 +kmod-sound-soc-core +kmod-regmap @BROKEN
+ DEPENDS:=@TARGET_ramips_mt7620 +kmod-sound-soc-core +kmod-regmap @!TARGET_ramips_rt288x
KCONFIG:= \
- CONFIG_SND_MT7620_SOC_I2S \
- CONFIG_SND_MT7620_SOC_WM8960
+ CONFIG_SND_RALINK_SOC_I2S \
+ CONFIG_SND_SOC_WM8960
FILES:= \
- $(LINUX_DIR)/sound/soc/ralink/snd-soc-mt7620-i2s.ko \
- $(LINUX_DIR)/sound/soc/ralink/snd-soc-mt7620-wm8960.ko \
+ $(LINUX_DIR)/sound/soc/ralink/snd-soc-ralink-i2s.ko \
$(LINUX_DIR)/sound/soc/codecs/snd-soc-wm8960.ko
- AUTOLOAD:=$(call AutoLoad,90,snd-soc-wm8960 snd-soc-mt7620-i2s snd-soc-mt7620-wm8960)
+ AUTOLOAD:=$(call AutoLoad,90,snd-soc-wm8960 snd-soc-ralink-i2s)
$(call AddDepends/sound)
endef