aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorShiji Yang <yangshiji66@qq.com>2022-11-05 19:52:08 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2022-11-05 21:12:24 +0100
commiteba0a8deb65de70b0d913f9ec8910640a79d0191 (patch)
tree8d8882c9ef732afcdb4fd155c24e24d06b3e25a2 /target/linux/ramips/image
parentd75ed3726d994fd050730e9ab5923d6232913054 (diff)
downloadupstream-eba0a8deb65de70b0d913f9ec8910640a79d0191.tar.gz
upstream-eba0a8deb65de70b0d913f9ec8910640a79d0191.tar.bz2
upstream-eba0a8deb65de70b0d913f9ec8910640a79d0191.zip
ramips: improve compatibility for Youku YK-L2 and YK-L1 series
Add UIMAGE_NAME and UIMAGE_MAGIC to allow users to directly install initramfs-kernel.bin from the stock firmware Web UI. At the same time, this change makes it possible to boot OpenWrt with the official u-boot. Notice: Since the stock firmware is based on OpenWrt and the configuration will be retained by default during the upgrade process, so we must use initramfs-kernel.bin to do a initial installation. After the system restarts, install sysupgrade.bin and do not retain any configuration. Signed-off-by: Shiji Yang <yangshiji66@qq.com>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7620.mk4
-rw-r--r--target/linux/ramips/image/mt7621.mk2
2 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index f6ad162779..db6ac93b2a 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -1281,6 +1281,8 @@ define Device/youku_yk-l1
DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-sdhci-mt7620 \
kmod-usb-ledtrig-usbport
SUPPORTED_DEVICES += youku-yk1 youku,yk1
+ UIMAGE_MAGIC := 0x12291000
+ UIMAGE_NAME := 400000000000000000000000
endef
TARGET_DEVICES += youku_yk-l1
@@ -1291,6 +1293,8 @@ define Device/youku_yk-l1c
DEVICE_MODEL := YK-L1c
DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-sdhci-mt7620 \
kmod-usb-ledtrig-usbport
+ UIMAGE_MAGIC := 0x12291000
+ UIMAGE_NAME := 400000000000000000000000
endef
TARGET_DEVICES += youku_yk-l1c
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 3ef4cf4efb..360513115f 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -2251,6 +2251,8 @@ define Device/youku_yk-l2
DEVICE_MODEL := YK-L2
DEVICE_PACKAGES := kmod-mt7603 kmod-mt76x2 kmod-usb3 \
kmod-usb-ledtrig-usbport
+ UIMAGE_MAGIC := 0x12291000
+ UIMAGE_NAME := 400000000000000000003000
endef
TARGET_DEVICES += youku_yk-l2