aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2023-10-24 18:05:28 +0100
committerDaniel Golle <daniel@makrotopia.org>2023-11-13 00:58:08 +0000
commitb38b5c42997e527f91e653a4b6d77a5717d3cd14 (patch)
tree36f81a6ca5ec81eadacc399051475954fd20729e /target/linux/ramips/image
parentce62536aca9d0aae9b21c3d19cd8ad6acba7b029 (diff)
downloadupstream-b38b5c42997e527f91e653a4b6d77a5717d3cd14.tar.gz
upstream-b38b5c42997e527f91e653a4b6d77a5717d3cd14.tar.bz2
upstream-b38b5c42997e527f91e653a4b6d77a5717d3cd14.zip
ramips: add support for MeiG SLT866 4G CPE
Hardware: - SoC: Mediatek MT7621 (MT7621AT) - Flash: 32 MiB SPI-NOR (Macronix MX25L25635E) - RAM: 128 MiB - Ethernet: Built-in, 2 x 1GbE - 3G/4G Modem: MEIG SLM828 (currently only supported with ModemManager) - SLIC: Si32185 (unsupported) - Power: 12V via barrel connector - Wifi 2.4GHz: Mediatek MT7603BE 802.11b/g/b - Wifi 5GHz: Mediatek MT7613BE 802.11ac/n/a - LEDs: 8x (7 controllable) - Buttons: 2x (RESET, WPS) Installing OpenWrt: - sysupgrade image is compatible with vendor firmware. Recovery: - Connect to any of the Ethernet ports, configure local IP: 10.10.10.3/24 (or 192.168.10.19/24, depending on OEM) - Provide firmware file named 'mt7621.img' on TFTP server. - Hold down both, RESET and WPS, then power on the board. - Watch network traffic using tcpdump or wireshark in realtime to observe progress of device requesting firmware. Once download has completed, release both buttons and wait until firmware comes up. Signed-off-by: Daniel Golle <daniel@makrotopia.org> (cherry picked from commit bc335f296740ac386e1ef09a49f1844419b0ccf9)
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index a5e3828c39..8a194d6bc1 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -1552,6 +1552,17 @@ define Device/mediatek_mt7621-eval-board
endef
TARGET_DEVICES += mediatek_mt7621-eval-board
+define Device/meig_slt866
+ $(Device/dsa-migration)
+ IMAGE_SIZE := 15104k
+ DEVICE_VENDOR := MeiG
+ DEVICE_MODEL := SLT866
+ DEVICE_PACKAGES := kmod-mt7603 kmod-mt7615e kmod-mt7663-firmware-ap \
+ kmod-usb-net-qmi-wwan kmod-usb-serial-option kmod-usb3 \
+ kmod-usb-net-rndis
+endef
+TARGET_DEVICES += meig_slt866
+
define Device/mercusys_mr70x-v1
$(Device/dsa-migration)
$(Device/tplink-safeloader)