aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorKarl Chan <exkc@exkc.moe>2023-01-29 13:37:28 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2023-02-12 18:27:45 +0100
commit92276eef704af0d74d067676de7e8b9966de91ca (patch)
tree3d362b8afd04b2d3babd7a1b7b5eaf34b2bb248d /target/linux/ramips/image
parent51982560a924bd9fe799d69d34013668bb2f694d (diff)
downloadupstream-92276eef704af0d74d067676de7e8b9966de91ca.tar.gz
upstream-92276eef704af0d74d067676de7e8b9966de91ca.tar.bz2
upstream-92276eef704af0d74d067676de7e8b9966de91ca.zip
ramips: add support for ASUS RT-AX54
Specifications: - Device: ASUS RT-AX54 (AX1800S/HP,AX54HP) - SoC: MT7621AT - Flash: 128MB - RAM: 256MB - Switch: 1 WAN, 4 LAN (10/100/1000 Mbps) - WiFi: MT7905 2x2 2.4G + MT7975 2x2 5G - LEDs: 1x POWER (blue, configurable) 1x LAN (blue, configurable) 1x WAN (blue, configurable) 1x 2.4G (blue, not configurable) 1x 5G (blue, not configurable) Flash by U-Boot TFTP method: - Configure your PC with IP 192.168.1.2 - Set up TFTP server and put the factory.bin image on your PC - Connect serial port(rate:115200) and turn on AP, then interrupt "U-Boot Boot Menu" by hitting any key Select "2. Upgrade firmware" Press enter when show "Run firmware after upgrading? (Y/n):" Select 0 for TFTP method Input U-Boot's IP address: 192.168.1.1 Input TFTP server's IP address: 192.168.1.2 Input IP netmask: 255.255.255.0 Input file name: openwrt-ramips-mt7621-asus_rt-ax1800hp-squashfs-factory.bin - Restart AP aftre see the log "Firmware upgrade completed!" Signed-off-by: Karl Chan <exkc@exkc.moe>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 8c8c6dee8e..e212ceabf3 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -338,6 +338,31 @@ define Device/asus_rt-ax53u
endef
TARGET_DEVICES += asus_rt-ax53u
+define Device/asus_rt-ax54
+ $(Device/dsa-migration)
+ DEVICE_VENDOR := ASUS
+ DEVICE_MODEL := RT-AX54
+ DEVICE_ALT0_VENDOR := ASUS
+ DEVICE_ALT0_MODEL := RT-AX54
+ DEVICE_ALT1_VENDOR := ASUS
+ DEVICE_ALT1_MODEL := RT-AX54HP
+ DEVICE_ALT2_VENDOR := ASUS
+ DEVICE_ALT2_MODEL := RT-AX1800HP
+ DEVICE_ALT3_VENDOR := ASUS
+ DEVICE_ALT3_MODEL := RT-AX1800S
+ IMAGE_SIZE := 51200k
+ UBINIZE_OPTS := -E 5
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ KERNEL_SIZE := 4096k
+ IMAGES += factory.bin
+ IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
+ IMAGE/factory.bin := append-kernel | pad-to $$(KERNEL_SIZE) | append-ubi | \
+ check-size
+ DEVICE_PACKAGES := kmod-mt7915-firmware uboot-envtools
+endef
+TARGET_DEVICES += asus_rt-ax54
+
define Device/beeline_smartbox-flash
$(Device/dsa-migration)
$(Device/uimage-lzma-loader)