aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorLinos Giannopoulos <linosgian00@gmail.com>2022-10-03 01:30:28 +0300
committerHauke Mehrtens <hauke@hauke-m.de>2022-11-05 23:13:16 +0100
commit78110c3b5fce119d13cd45dadd33ca396c8ce197 (patch)
tree692c2bd58387e9bdc989942c7301cf9eeae35d36 /target/linux/ramips/image
parentf7f9203854c7173a91655683aa7ad2a0af43f518 (diff)
downloadupstream-78110c3b5fce119d13cd45dadd33ca396c8ce197.tar.gz
upstream-78110c3b5fce119d13cd45dadd33ca396c8ce197.tar.bz2
upstream-78110c3b5fce119d13cd45dadd33ca396c8ce197.zip
ramips: add support for TP-Link MR600 V2(EU)
MR600 V2(EU) is an LTE router that also supports 4G+ band aggregation etc. and can reportedly achieve higher bandwidth with it. - Specifications: * SoC: Mediatek MT7621DAT 880MHz * RAM: 128MB DDR3 * Flash: 16MB SPI NOR flash (GD25Q128C) * LTE Modem: Qualcomm MDM9240 * WiFi 5GHz: Mediatek MT7613BEN * WiFi 2.4GHz: Mediatek MT7603EN * Ethernet: MT7530, 4x 1000Base-T. * UART: Serial console (115200 8n1), J1(GND:3) * Buttons: Reset, WPS. * LED: Power, WAN, LTE, WiFi 2GHz and 5GHz, LAN, Signal1, Signal2, Signal3 - MAC Addresses: OEM firmware configuration: 54:af:97:xx:xx:7b : 2.4G 54:af:97:xx:xx:7a : 5G 54:af:97:xx:xx:7c : LTE 54:af:97:xx:xx:7b : LAN (label) 54:af:97:xx:xx:7c : WAN - Installation: 1. Download the OpenWrt initramfs-image. Place it into a TFTP server root directory and rename it to openwrt.img Configure the TFTP server to listen at 192.168.0.5/24. 3. Connect to the serial console. Attach power and interrupt the boot procedure when prompted (type `tpl`). Credentials are admin / 1234 4. Configure U-Boot for booting OpenWrt from ram $ tftpboot $ bootm 5. Transfer the OpenWrt sysupgrade image to the device. - LTE: In order to setup the wwan0 interface: 1. Add a `qmi` proto interface under `/etc/config/network`, e.g.: ``` config interface 'wwan0' option device '/dev/cdc-wdm0' option proto 'qmi' option pincode 'XXXX' option apn 'your_isp_apn' ``` 2. Add `wwan0` interface to the `wan` firewall zone 3. `/etc/init.d/network restart` Signed-off-by: Linos Giannopoulos <linosgian00@gmail.com>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 60f927eeed..35817d0317 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -1910,6 +1910,21 @@ define Device/tplink_eap615-wall-v1
endef
TARGET_DEVICES += tplink_eap615-wall-v1
+define Device/tplink_mr600-v2-eu
+ $(Device/dsa-migration)
+ $(Device/tplink-v2)
+ DEVICE_MODEL := MR600
+ DEVICE_VARIANT := v2 (EU)
+ TPLINK_FLASHLAYOUT := 16Mltq
+ DEVICE_PACKAGES := kmod-mt7603 kmod-mt7615e kmod-mt7663-firmware-ap \
+ kmod-usb-net-qmi-wwan uqmi kmod-usb3
+ KERNEL := $(KERNEL_DTB) | uImage lzma
+ KERNEL_INITRAMFS := $$(KERNEL) | tplink-v2-header
+ TPLINK_BOARD_ID := MR600-V2-EU
+ IMAGE_SIZE := 16384k
+endef
+TARGET_DEVICES += tplink_mr600-v2-eu
+
define Device/tplink_re350-v1
$(Device/dsa-migration)
$(Device/tplink-safeloader)