aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorLeon M. Busch-George <leon@georgemail.eu>2022-11-12 19:31:41 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2023-01-06 19:22:52 +0100
commitf6d394e9f2fd41547236c092ac914322220eb77c (patch)
tree30c0f239fdb9e0404f4be23d8390d07f69c2ed1d /target/linux/ramips/image
parented7c1a504eae6b220e01da330c62c47d299e2c5d (diff)
downloadupstream-f6d394e9f2fd41547236c092ac914322220eb77c.tar.gz
upstream-f6d394e9f2fd41547236c092ac914322220eb77c.tar.bz2
upstream-f6d394e9f2fd41547236c092ac914322220eb77c.zip
ramips: add support for Cudy M1800
Specifications SoC: MT7621 CPU: 880 MHz Flash: 32 MiB RAM: 256 MiB WLAN: MT7915 WiFi 6 (2.4/5 GHz) Ethernet: 2x Gbit ports MAC LAN b4:4b:d6:2e:c7:b0 (label) WAN b4:4b:d6:2e:c7:b1 WiFi 2.4 00:0c:43:26:46:08 WiFi 5 00:0c:43:26:59:97 Installation There are two known options: 1) The Luci-based UI. 2) Press and hold the reset button during power up. The router will request 'recovery.bin' from a TFTP server at 192.168.1.88. Both options require a signed firmware binary. The openwrt image supplied by cudy is signed and can be used to install unsigned images. Signed-off-by: Leon M. Busch-George <leon@georgemail.eu>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 1b4e1dc039..2fc193634b 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -426,6 +426,16 @@ define Device/bolt_arion
endef
TARGET_DEVICES += bolt_arion
+define Device/cudy_m1800
+ $(Device/dsa-migration)
+ DEVICE_VENDOR := Cudy
+ DEVICE_MODEL := M1800
+ IMAGE_SIZE := 16064k
+ UIMAGE_NAME := R17
+ DEVICE_PACKAGES := kmod-mt7915e
+endef
+TARGET_DEVICES += cudy_m1800
+
define Device/cudy_wr1300-v1
$(Device/dsa-migration)
IMAGE_SIZE := 15872k