aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorMaximilian Weinmann <x1@disroot.org>2022-11-04 00:23:44 +0700
committerHauke Mehrtens <hauke@hauke-m.de>2023-05-07 14:44:54 +0200
commitecdb24814f540cb67cfa0ca64f32d76889853d15 (patch)
treefa97249452d5cb9d03b78abdf6143570361432be /target/linux/ramips/image
parent1108f6cb8b115608c486552f1210fea5b955ea5f (diff)
downloadupstream-ecdb24814f540cb67cfa0ca64f32d76889853d15.tar.gz
upstream-ecdb24814f540cb67cfa0ca64f32d76889853d15.tar.bz2
upstream-ecdb24814f540cb67cfa0ca64f32d76889853d15.zip
ramips: add support for SNR-CPE-ME1
SNR-CPE-ME1 is a wireless WiFi 5 router manufactured by SNR/NAG company. Specification: - SoC : MediaTek MT7621A - RAM : DDR3 256 MiB - Flash : SPI-NOR 16 MiB (GD25Q128CSIG) - WLAN : 2.4 GHz (MediaTek MT7603EN) 5 GHz (MediaTek MT7610EN) - Ethernet : 10/100/1000 Mbps x5 - Switch : MediaTek MT7530 (in SoC) - USB : 3.0 x1 - UART : through-hole on PCB - [J4] 3.3V, RX, TX, GND (57600n8) - Power : 12 VDC, 2 A Flash instruction via TFTP: 1. Boot SNR-CPE-ME1 to recovery mode (hold the reset button while power on) 2. Send firmware via TFTP client: TFTP Server address: 192.168.1.1 TFTP Client address: 192.168.1.131 3. Wait ~120 seconds to complete flashing 4. Do sysupgrade using web-interface Signed-off-by: Maximilian Weinmann <x1@disroot.org>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 3e910e88f6..d33937a8d7 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -2031,6 +2031,18 @@ define Device/sim_simax1800t
endef
TARGET_DEVICES += sim_simax1800t
+define Device/snr_snr-cpe-me1
+ $(Device/dsa-migration)
+ $(Device/uimage-lzma-loader)
+ IMAGE_SIZE := 15040k
+ DEVICE_VENDOR := SNR
+ DEVICE_MODEL := SNR-CPE-ME1
+ UIMAGE_NAME := SNR-CPE-ME1-5GHZ-MT
+ DEVICE_PACKAGES := kmod-mt7603 kmod-mt76x0e kmod-usb3 \
+ kmod-usb-ledtrig-usbport uboot-envtools
+endef
+TARGET_DEVICES += snr_snr-cpe-me1
+
define Device/snr_snr-cpe-me2-lite
$(Device/dsa-migration)
$(Device/uimage-lzma-loader)