aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorFelix Baumann <felix.bau@gmx.de>2023-04-21 03:39:38 +0200
committerDavid Bauer <mail@david-bauer.net>2023-05-02 18:24:52 +0200
commite38de40f8dd350344407fe5a91e81191f6960804 (patch)
tree7fe9a1f197ef91eddfbb8ebc191b1bcf3768f087 /target/linux/ramips/image
parentcf8d861978dbfdb572a25db460db464b50d9e809 (diff)
downloadupstream-e38de40f8dd350344407fe5a91e81191f6960804.tar.gz
upstream-e38de40f8dd350344407fe5a91e81191f6960804.tar.bz2
upstream-e38de40f8dd350344407fe5a91e81191f6960804.zip
ramips: mt7621: add support for Cudy X6 v2
Rename existing device to v1 and create common .dtsi Difference to v1: 16MB Flash Specifications: SoC: MediaTek MT7621 RAM: 256 MB Flash: 16 MB (SPI NOR, XM25QH128C on my device) WiFi: MediaTek MT7915E Switch: 1 WAN, 4 LAN (Gigabit) Buttons: Reset, WPS LEDs: Two Power LEDs (blue and red; together they form purple) Power: DC 12V 1A center positive Serial: 115200 8N1 C440 - (3V3 - GND - RX - TX) - C41 | v1 and v2 (P - G - R - T) | v2 labels them on the board Installation: Download and flash the manufacturer's built OpenWrt image available at http://www.cudytech.com/openwrt_software_download Install the new OpenWrt image via luci (System -> Backup/Flash firmware) Be sure to NOT keep settings. Recovery: Loads only signed manufacture firmware due to bootloader RSA verification Serve tftp-recovery image as /recovery.bin on 192.168.1.88/24 Connect to any lan ethernet port Power on the device while holding the reset button Wait at least 8 seconds before releasing reset button for image to download MAC addresses as verified by OEM firmware: use address source LAN f4:a4:54:86:75:a2 label WAN f4:a4:54:86:75:a3 label + 1 2g f4:a4:54:86:75:a2 label 5g f6:a4:54:b6:75:a2 label + LA-Bit set + 4th oktet increased The label MAC address is found in bdinfo 0xde00. Signed-off-by: Felix Baumann <felix.bau@gmx.de>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk19
1 files changed, 16 insertions, 3 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 24daba43aa..135febe3a6 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -543,16 +543,29 @@ define Device/cudy_wr2100
endef
TARGET_DEVICES += cudy_wr2100
-define Device/cudy_x6
+define Device/cudy_x6-v1
$(Device/dsa-migration)
IMAGE_SIZE := 32256k
DEVICE_VENDOR := Cudy
DEVICE_MODEL := X6
+ DEVICE_VARIANT := v1
UIMAGE_NAME := R13
DEVICE_PACKAGES := kmod-mt7915-firmware -uboot-envtools
- SUPPORTED_DEVICES += R13
+ SUPPORTED_DEVICES += cudy,x6 R13
+endef
+TARGET_DEVICES += cudy_x6-v1
+
+define Device/cudy_x6-v2
+ $(Device/dsa-migration)
+ IMAGE_SIZE := 15872k
+ DEVICE_VENDOR := Cudy
+ DEVICE_MODEL := X6
+ DEVICE_VARIANT := v2
+ UIMAGE_NAME := R30
+ DEVICE_PACKAGES := kmod-mt7915-firmware -uboot-envtools
+ SUPPORTED_DEVICES += cudy,x6 R30
endef
-TARGET_DEVICES += cudy_x6
+TARGET_DEVICES += cudy_x6-v2
define Device/dlink_dap-1620-b1
DEVICE_VENDOR := D-Link