aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorMark Ceeha <hi@shiz.me>2023-01-29 16:01:40 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2023-02-03 12:13:50 +0100
commitd4c63c77866bf09668b541760b6c9f277b41ac87 (patch)
tree033201e5554169f5277c0e549de3e0ccea2a63a3 /target/linux/ramips/image
parentc97bcec15a6f524089ffe17ad2435d107867da35 (diff)
downloadupstream-d4c63c77866bf09668b541760b6c9f277b41ac87.tar.gz
upstream-d4c63c77866bf09668b541760b6c9f277b41ac87.tar.bz2
upstream-d4c63c77866bf09668b541760b6c9f277b41ac87.zip
ramips: add support for TP-Link Deco M4R v4
This commit adds support for the V4 hardware revision of the Deco M4R. V4 is a complete overhaul of the hardware compared to V1 and V2, and is much more similar to the Archer C6 V3 and C6U V1. Specifications: SoC: MediaTek MT7621AT (2 cores at 880 MHz, 4 threads) RAM: Kingston D1216ECMDXGJD (256 MB) Wireless 2.4 GHz: MediaTek MT7603EN Wireless 5 GHz: MediaTek MT7613BEN Flash: 16 MB SPI NOR Installation: Flash the *-factory.bin image in the U-Boot recovery webserver. You can trigger this webserver by holding the reset button until the LED flashes yellow, or by hooking up to serial pads on the board (clearly labeled GND, RX and TX) and pressing `x` early in boot. Once the factory image has been flashed, you can use the regular upgrade procedure with sysupgrade images for subsequent flashes. Signed-off-by: Mark Ceeha <hi@shiz.me> Tested-by: Mark Ceeha <hi@shiz.me>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 3587fb613a..7f4f338039 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -2014,6 +2014,18 @@ define Device/tplink_archer-c6u-v1
endef
TARGET_DEVICES += tplink_archer-c6u-v1
+define Device/tplink_deco-m4r-v4
+ $(Device/dsa-migration)
+ $(Device/tplink-safeloader)
+ DEVICE_MODEL := Deco M4R
+ DEVICE_VARIANT := v4
+ DEVICE_PACKAGES := kmod-mt7603 kmod-mt7615e kmod-mt7663-firmware-ap
+ KERNEL := $(KERNEL_DTB) | uImage lzma
+ TPLINK_BOARD_ID := DECO-M4R-V4
+ IMAGE_SIZE := 15744k
+endef
+TARGET_DEVICES += tplink_deco-m4r-v4
+
define Device/tplink_eap235-wall-v1
$(Device/dsa-migration)
$(Device/tplink-safeloader)