aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2022-11-17 22:48:10 +0100
committerDavid Bauer <mail@david-bauer.net>2022-12-07 12:30:29 +0100
commitbc14925f3de510937a5a73598fda481f5c00ee26 (patch)
tree9b26acb083cf0b35f8e6807aa61a447a4ef732ba /target/linux/ramips/image
parent8138d66fccd1131eb18f47ed1d16a24c7ce89b99 (diff)
downloadupstream-bc14925f3de510937a5a73598fda481f5c00ee26.tar.gz
upstream-bc14925f3de510937a5a73598fda481f5c00ee26.tar.bz2
upstream-bc14925f3de510937a5a73598fda481f5c00ee26.zip
ramips: define loadaddr for all UniFi devices
Define the load-address for the DTB of all Ubiquiti UniFi devices using FIT images. From the GPL code we can assume these boards are affected by the same relocating issue with the vendor bootloader. Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 18ac8ac136..9d8641352a 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -2064,6 +2064,7 @@ define Device/ubnt_unifi-flexhd
DEVICE_VENDOR := Ubiquiti
DEVICE_MODEL := UniFi FlexHD
DEVICE_DTS_CONFIG := config@2
+ DEVICE_DTS_LOADADDR := 0x87000000
KERNEL := kernel-bin | lzma | fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb
DEVICE_PACKAGES += kmod-mt7603 kmod-mt7615e kmod-mt7615-firmware kmod-leds-ubnt-ledbar
IMAGE_SIZE := 15552k
@@ -2084,6 +2085,7 @@ define Device/ubnt_usw-flex
DEVICE_VENDOR := Ubiquiti
DEVICE_MODEL := UniFi Switch Flex
DEVICE_DTS_CONFIG := config@1
+ DEVICE_DTS_LOADADDR := 0x87000000
KERNEL := kernel-bin | lzma | fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb
IMAGE_SIZE := 7360k
endef