aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorDaniel Fuchs <software@sagacioussuricata.com>2022-10-25 01:13:30 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2022-11-13 22:36:06 +0100
commit794d1645b3d4e6735b4a749f39cfeaa05f60b101 (patch)
tree1a36663c2dbf9cd5d62015524db9a4eb1977d0c4 /target/linux/ramips/image
parent0cfd15552e335528743f1fcc4961959126788bf5 (diff)
downloadupstream-794d1645b3d4e6735b4a749f39cfeaa05f60b101.tar.gz
upstream-794d1645b3d4e6735b4a749f39cfeaa05f60b101.tar.bz2
upstream-794d1645b3d4e6735b4a749f39cfeaa05f60b101.zip
ramips: add support for Amped Wireless B1200EX
This device is almost identical to the already supported Edimax EW-7476RP5, the only differences are: - There is no mode selection slider switch on this device - The two wireless LEDs are green instead of blue - Model name in the CSYS header is RN10 Additional changes: - Moved WiFi LEDs and the slider switch to the individual dt files - Added ieee80211-freq-limit to the mt7612e radio to properly disable 2.4GHz band on this radio Device specifications: SoC: MediaTek MT7620a @ 580MHz RAM: 64M (Winbond W9751G6KB-25) FLASH: 8MB (Macronix) WiFi: SoC-integrated: MediaTek MT7620a bgn WiFi: MediaTek MT7612EN nac GbE: 1x (RTL8211E) BTN: WPS/RESET LED: - WiFi 5G (green) - WiFi 2.4G (green) - Signal Strength (green) - Power (green) - WPS (green) - LAN (green) UART: UART is present as Pads with throughholes on the PCB. They are located next to the WPS button 3.3V - RX - GND - TX / 57600-8N1 3.3V is the square pad Installation: Upload the sysupgrade image via the default web interface Signed-off-by: Daniel Fuchs <software@sagacioussuricata.com>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7620.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 231f6ad47d..6c22dfbbdd 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -75,6 +75,19 @@ define Device/amit_jboot
DEVICE_PACKAGES := jboot-tools kmod-usb2 kmod-usb-ohci
endef
+define Device/ampedwireless_b1200ex
+ SOC := mt7620a
+ DEVICE_VENDOR := Amped Wireless
+ DEVICE_MODEL := B1200EX
+ BLOCKSIZE := 4k
+ IMAGE_SIZE := 7744k
+ IMAGE/sysupgrade.bin := append-kernel | append-rootfs | \
+ edimax-header -s CSYS -m RN10 -f 0x70000 -S 0x01100000 | pad-rootfs | \
+ check-size | append-metadata
+ DEVICE_PACKAGES := kmod-mt76x2 kmod-phy-realtek
+endef
+TARGET_DEVICES += ampedwireless_b1200ex
+
define Device/asus_rp-n53
SOC := mt7620a
IMAGE_SIZE := 7872k