aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorBin We <me@udp.pw>2022-09-23 01:04:01 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2023-04-02 19:25:37 +0200
commit6b66666da46dd50d4bd2cb1b94fd35ec7f10e54c (patch)
tree69a6598ea75cca3a2757fc3a38a92f153fe7e475 /target/linux/ramips/image
parent90603d443f56da034c8e8e4f1aeee4c8975413e6 (diff)
downloadupstream-6b66666da46dd50d4bd2cb1b94fd35ec7f10e54c.tar.gz
upstream-6b66666da46dd50d4bd2cb1b94fd35ec7f10e54c.tar.bz2
upstream-6b66666da46dd50d4bd2cb1b94fd35ec7f10e54c.zip
ramips: add support for OrayBox X1
Add support for OrayBox X1. It is a 802.11n router, based on MediaTek MT7628N. Specifications: SoC: MediaTek MT7628N (580MHz) RAM: 64 MiB Flash: 16 MiB NOR (Winbond W25Q128JVSIQ) Wireless: 802.11b/g/n 2x2 2.4GHz (Built In) Ethernet: 1x 100Mbps only USB: 1x USB Type-A 2.0 Host Port Button: 1x "Reset" button LED: 1x Blue LED + 1x Red LED + 1x White LED Power: 5V Micro-USB input Manufacturer Page: https://pgy.oray.com/router/x1.html/parameter Flash Layout: 0x000000000000-0x000000030000 : "u-boot" 0x000000030000-0x000000040000 : "kpanic" 0x000000040000-0x000000050000 : "factory" 0x000000050000-0x000000fe0000 : "firmware" 0x000000fe0000-0x000000ff0000 : "bdinfo" 0x000000ff0000-0x000001000000 : "reserve" Install via SSH: Original firmware is based on OpenWRT, but SSH is not start by default, You should enable it first 1. Login into web admin (10.168.1.1), default password is 'admin' 2. Open the following link, and the result should be {"code":0}; SSH is now started, username is root, password is same as web admin password http://10.168.1.1/cgi-bin/oraybox?_api=ssh_set&enabled=1 4. You can flash firmware via mtd: mtd write /tmp/firmware_image.bin firmware Signed-off-by: Bin We <me@udp.pw>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt76x8.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 296b80d03f..fd16606f3f 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -474,6 +474,14 @@ define Device/onion_omega2p
endef
TARGET_DEVICES += onion_omega2p
+define Device/oraybox_x1
+ IMAGE_SIZE := 15360k
+ DEVICE_VENDOR := OrayBox
+ DEVICE_MODEL := X1
+ DEVICE_PACKAGES:= kmod-usb2 kmod-usb-ohci
+endef
+TARGET_DEVICES += oraybox_x1
+
define Device/rakwireless_rak633
IMAGE_SIZE := 7872k
DEVICE_VENDOR := Rakwireless