aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorIvaylo Ivanov <iivailo@mail.bg>2022-08-25 09:10:13 +0300
committerHauke Mehrtens <hauke@hauke-m.de>2022-11-13 22:36:06 +0100
commit6afc355b2e120ff2701cc9aca66af19c6a0aeca2 (patch)
tree296666a47e97a1bae592e3461c471bcc48655ee7 /target/linux/ramips/image
parent794d1645b3d4e6735b4a749f39cfeaa05f60b101 (diff)
downloadupstream-6afc355b2e120ff2701cc9aca66af19c6a0aeca2.tar.gz
upstream-6afc355b2e120ff2701cc9aca66af19c6a0aeca2.tar.bz2
upstream-6afc355b2e120ff2701cc9aca66af19c6a0aeca2.zip
ramips: Add support for D-Link DIR-3060 A1
Hardware specification: SoC: MediaTek MT7621AT Flash: Winbond W29N01HVSINA 128MB RAM: Micron MT41K128M16JT-125 256MB Ethernet: 4x 10/100/1000 Mbps WiFi1: MT7615DN 2.4GHz N 2x2:2 WiFi2: MT7615DN 5GHz AC 2x2:2 WiFi3: MT7615N 5GHz AC 4x4:4 Button: WPS, Reset Flash instructions: OpenWrt can be installed via D-Link Recovery GUI: Push and hold reset button (on the bottom of the device) until power led starts flashing (about 10 secs or so) while plugging in the power cable. Give it ~30 seconds, to boot the recovery mode GUI Connect your client computer to LAN1 of the device Set your client IP address manually to 192.168.0.2 / 255.255.255.0. Call the recovery page for the device at http://192.168.0.1/ Use the provided emergency web GUI to upload and flash a new firmware to the device Signed-off-by: Ivaylo Ivanov <iivailo@mail.bg>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index e7b38aaacf..81ee50e0af 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -547,6 +547,13 @@ define Device/dlink_dir-2660-a1
endef
TARGET_DEVICES += dlink_dir-2660-a1
+define Device/dlink_dir-3060-a1
+ $(Device/dlink_dir-xx60-a1)
+ DEVICE_MODEL := DIR-3060
+ DEVICE_VARIANT := A1
+endef
+TARGET_DEVICES += dlink_dir-3060-a1
+
define Device/dlink_dir-853-a3
$(Device/dlink_dir-xx60-a1)
DEVICE_MODEL := DIR-853