aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorSergei Iudin <tsipa740@gmail.com>2020-06-17 15:44:30 -0700
committerHauke Mehrtens <hauke@hauke-m.de>2022-07-03 22:14:05 +0200
commit4b0c433c39fc1aa28ba0af01987017330d555379 (patch)
tree55d49793776857ea1bdc2d7cf169fe232747bac7 /target/linux/ramips/image
parent576b62712fa7552f4fa30b67b47004745fee5287 (diff)
downloadupstream-4b0c433c39fc1aa28ba0af01987017330d555379.tar.gz
upstream-4b0c433c39fc1aa28ba0af01987017330d555379.tar.bz2
upstream-4b0c433c39fc1aa28ba0af01987017330d555379.zip
ramips: Add suport for COMFAST CF-WR617AC
Specifications: Chipset:MT7628DA+MT7612E Antenna : 2.4Ghz:2x5dbi Antenna + 5.8Ghz:2x5dbi Antenna Wireless Rate:2.4Ghz 300Mbps , 5.8Ghz 867Mbps Output Power :100mW(20dbm) Physical port:110/100Mbps RJ45 WAN Port , 310/100Mbps RJ45 LAN Port Flash: 8Mb DRam: 64Mb Flashing: default bootloader attempts to boot from tftp://192.168.1.10/firmware_auto.bin using 192.168.1.1 Known issues: mac-address-increment for 5GHZ doesnt work, i failed to figure out why. Original firmware using +1 from original value in factory partition. Signed-off-by: Sergei Iudin <tsipa740@gmail.com>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt76x8.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 5bb9bf61b7..5c10159568 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -107,6 +107,15 @@ define Device/buffalo_wcr-1166ds
endef
TARGET_DEVICES += buffalo_wcr-1166ds
+define Device/comfast_cf-wr617ac
+ IMAGE_SIZE := 7872k
+ DTS := CF-WR617AC
+ DEVICE_VENDOR := Comfast
+ DEVICE_MODEL := CF-WR617AC
+ DEVICE_PACKAGES := kmod-mt76x2 kmod-rt2800-pci
+endef
+TARGET_DEVICES += comfast_cf-wr617ac
+
define Device/comfast_cf-wr758ac
IMAGE_SIZE := 7872k
DEVICE_VENDOR := COMFAST