aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorFelix Baumann <felix.bau@gmx.de>2023-04-21 03:07:58 +0200
committerDavid Bauer <mail@david-bauer.net>2023-04-24 02:57:26 +0200
commit45cf200b2e22c34f2ae043b87e24230de526fefc (patch)
treeff0394603fa370d442df823e0961dc54e9f29d5e /target/linux/ramips/image
parent097f350aebc542963c7208af4973ff17e01ce76e (diff)
downloadupstream-45cf200b2e22c34f2ae043b87e24230de526fefc.tar.gz
upstream-45cf200b2e22c34f2ae043b87e24230de526fefc.tar.bz2
upstream-45cf200b2e22c34f2ae043b87e24230de526fefc.zip
ramips: Cudy X6 fixes / improvements
- Correct WiFi MACs, they didn't match oem firmware - Move nvmem-cells to bdinfo partition and remove &bdinfo reference - Add OEM device model name R13 to SUPPORTED_DEVICES This allows sysupgrading from Cudy's OpenWrt fork without force - Label red_led and use it during failsafe mode and upgrades MAC addresses as verified by OEM firmware: use address source LAN b4:4b:d6:2d:c8:4a label WAN b4:4b:d6:2d:c8:4b label + 1 2g b4:4b:d6:2d:c8:4a label 5g b6:4b:d6:3d:c8:4a label + LA-Bit set + 4th oktet increased The label MAC address is found in bdinfo 0xde00. Signed-off-by: Felix Baumann <felix.bau@gmx.de> [read wifi mac from flash offset] Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index d46d84e6ce..df89877c9a 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -527,6 +527,7 @@ define Device/cudy_x6
DEVICE_MODEL := X6
UIMAGE_NAME := R13
DEVICE_PACKAGES := kmod-mt7915-firmware -uboot-envtools
+ SUPPORTED_DEVICES += R13
endef
TARGET_DEVICES += cudy_x6