aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorAlexey Bartenev <41exey@proton.me>2022-10-24 22:50:33 +0700
committerHauke Mehrtens <hauke@hauke-m.de>2022-12-17 22:34:44 +0100
commit3f201d1f8ece4ed363428f353558d44f9dbe98a5 (patch)
tree3c1fc3e7653ccceedcd00a9ae9a3a1ff33a3efcd /target/linux/ramips/image
parenta442974cfa89c7182c37b3b422b2d49319e2b339 (diff)
downloadupstream-3f201d1f8ece4ed363428f353558d44f9dbe98a5.tar.gz
upstream-3f201d1f8ece4ed363428f353558d44f9dbe98a5.tar.bz2
upstream-3f201d1f8ece4ed363428f353558d44f9dbe98a5.zip
ramips: add support for SNR-CPE-W4N-MT router
General specification: - SoC Type: MediaTek MT7620N (580MHz) - ROM: 8 MB SPI-NOR (W25Q64FV) - RAM: 64 MB DDR (M13S5121632A) - Switch: MediaTek MT7530 - Ethernet: 5 ports - 5×100MbE (WAN, LAN1-4) - Wireless 2.4 GHz: b/g/n - Buttons: 1 button (RESET) - Bootloader: U-Boot 1.1.3, MediaTek U-Boot: 5.0.0.5 - Power: 12 VDC, 1.0 A Flash by the native uploader in 2 stages: 1. Use the native uploader to flash an initramfs image. Choose openwrt-ramips-mt7620-snr_cpe-w4n-mt-initramfs-kernel.bin file by "Administration/Management/Firmware update/Choose File" in vendor's web interface (ip: 192.168.1.10, login: Admin, password: Admin). Wait ~160 seconds. 2. Flash a sysupgrade image via the initramfs image. Choose openwrt-ramips-mt7620-snr_cpe-w4n-mt-squashfs-sysupgrade.bin file by "System/Backup/Flash Firmware/Flash image..." in LuCI web interface (ip: 192.168.1.1, login: root, no password). Wait ~240 seconds. Flash by U-Boot TFTP method: 1. Configure your PC with IP 192.168.1.131 2. Set up TFTP server and put the openwrt-ramips-mt7620-snr_cpe-w4n-mt-squashfs-sysupgrade.bin image on your PC 3. Connect serial port (57600 8N1) and turn on the router. Then interrupt "U-Boot Boot Menu" by hitting 2 key (select "2: Load system code then write to Flash via TFTP."). Press Y key when show "Warning!! Erase Linux in Flash then burn new one. Are you sure? (Y/N)" Input device IP (192.168.1.1) ==:192.168.1.1 Input server IP (192.168.1.131) ==:192.168.1.131 Input Linux Kernel filename () ==: openwrt-ramips-mt7620-snr_cpe-w4n-mt-squashfs-sysupgrade.bin 3. Wait ~120 seconds to complete flashing Signed-off-by: Alexey Bartenev <41exey@proton.me>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7620.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 7fff06665e..445d3dec34 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -1104,6 +1104,17 @@ define Device/sitecom_wlr-4100-v1-002
endef
TARGET_DEVICES += sitecom_wlr-4100-v1-002
+define Device/snr_cpe-w4n-mt
+ $(Device/uimage-lzma-loader)
+ SOC := mt7620n
+ IMAGE_SIZE := 7360k
+ DEVICE_VENDOR := SNR
+ DEVICE_MODEL := CPE-W4N
+ DEVICE_VARIANT := MT
+ UIMAGE_NAME := SNR-CPE-W4N-MT
+endef
+TARGET_DEVICES += snr_cpe-w4n-mt
+
define Device/tplink_archer-c20i
$(Device/tplink-v2)
SOC := mt7620a