aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2023-07-28 11:41:14 +0200
committerPiotr Dymacz <pepe2k@gmail.com>2023-09-11 13:49:07 +0200
commit3cc223243b848b87a4c82b219f24cdb17ee9a771 (patch)
tree1f78ec51b781427c1822bd33f1500bb601b70d17 /target/linux/ramips/image
parenta7449e5e9532d4ba3022ae88a05bfd44021e2543 (diff)
downloadupstream-3cc223243b848b87a4c82b219f24cdb17ee9a771.tar.gz
upstream-3cc223243b848b87a4c82b219f24cdb17ee9a771.tar.bz2
upstream-3cc223243b848b87a4c82b219f24cdb17ee9a771.zip
ramips: add support for ALFA Network AX1800RM
ALFA Network AX1800RM (FCC ID: 2AB877621) is a dual-band Wi-Fi 6 (AX1800) router, based on MediaTek MT7621A + MT79x5D platform. Specifications: - SOC: MT7621A (880 MHz) - DRAM: DDR3 256 MiB (Nanya NT5CC128M16JR-EK) - Flash: 16 MiB SPI NOR (EN25QH128A-104HIP) - Ethernet: 4x 10/100/1000 Mbps (SOC's built-in switch) - Wi-Fi: 2x2:2 2.4/5 GHz (MT7905DAN + MT7975DN) (MT7905DAN doesn't support background DFS scan/BT) - LED: 6x green, 1x green/red - Buttons: 2x (reset, WPS) - Antenna: 4x external, non-detachable omnidirectional - UART: 1x 4-pin (2.54 mm pitch, J4, not populated) - Power: 12 V DC/1 A (DC jack) MAC addresses: LAN: 00:c0:ca:xx:xx:4e (factory 0x4, +2) WAN: 00:c0:ca:xx:xx:4f (factory 0x4, +3) 2.4 GHz: 00:c0:ca:xx:xx:4c (factory 0x4, device's label) 5 GHz: 00:c0:ca:xx:xx:4c (factory 0xa) Flash instructions for web-based U-Boot recovery: 1. Power the device with WPS button pressed and wait around 10 seconds. 2. Setup static IP 192.168.1.2/24 on your PC. 3. Go to 192.168.1.1 in browser and upload 'recovery' image. The device runs LEDE 17.01 (kernel 4.4.x) based firmware with 'failsafe' mode available which allows alternative upgrade method: 1. Run device in 'failsafe' mode and change password for default user. 2. SSH to the device, transfer 'sysupgrade' image and perform upgrade in forced mode, without preserving settings: 'sysupgrade -n -F ...'. Other notes: If you own early version of this device, the vendor firmware might refuse OpenWrt image because of missing custom header. In that case, ask vendor's customer support for stock firmware without custom header support/requirement. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com> (backported from commit f1aaa267f0ea18ffe5840f3ce46a48be123d2f62)
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index fa4c83dbe1..2675c7d08b 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -178,6 +178,18 @@ define Device/afoundry_ew1200
endef
TARGET_DEVICES += afoundry_ew1200
+define Device/alfa-network_ax1800rm
+ $(Device/dsa-migration)
+ IMAGE_SIZE := 15488k
+ DEVICE_VENDOR := ALFA Network
+ DEVICE_MODEL := AX1800RM
+ DEVICE_PACKAGES := kmod-mt7915-firmware
+ KERNEL := kernel-bin | lzma | fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb
+ IMAGES += recovery.bin
+ IMAGE/recovery.bin := append-kernel | append-rootfs | pad-rootfs | check-size
+endef
+TARGET_DEVICES += alfa-network_ax1800rm
+
define Device/alfa-network_quad-e4g
$(Device/dsa-migration)
IMAGE_SIZE := 16064k