aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorSebastian Schaper <openwrt@sebastianschaper.net>2023-01-07 13:45:44 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2023-01-07 17:56:10 +0100
commit3c31f6b521bb5fc49e222a8f2bcd454b73452a0e (patch)
treecf688f668119769ff697c824e8782dd12bdc5edf /target/linux/ramips/image
parent11759a5bf3c62846ded3d8946322802d41ac8984 (diff)
downloadupstream-3c31f6b521bb5fc49e222a8f2bcd454b73452a0e.tar.gz
upstream-3c31f6b521bb5fc49e222a8f2bcd454b73452a0e.tar.bz2
upstream-3c31f6b521bb5fc49e222a8f2bcd454b73452a0e.zip
ramips: add support for D-Link DAP-X1860 A1
The DAP-X1860 is a wall-plug AX1800 repeater. Specifications: - MT7621, 256 MiB RAM, 128 MiB SPI NAND - MT7915 + MT7975 2x2 802.11ax (DBDC) - Ethernet: 1 port 10/100/1000 - LED RSSI bargraph (2x green, 1x red/orange), status and RSSI LEDs are incorrectly populated red/orange (should be red/green according to documentation) Installation: - Keep reset button pressed during plug-in - Web Recovery Updater is at 192.168.0.50 - Upload factory.bin, confirm flashing (seems to work best with Chromium-based browsers) Revert to OEM firmware: - tar -xvf DAP-X1860_RevA_Firmware_101b94.bin - openssl enc -d -md md5 -aes-256-cbc -in FWImage.st2 \ -out FWImage.st1 -k MB0dBx62oXJXDvt12lETWQ== - tar -xvf FWImage.st1 - flash kernel_DAP-X1860.bin via Recovery Signed-off-by: Sebastian Schaper <openwrt@sebastianschaper.net>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index cbcf67c236..2269833e48 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -478,6 +478,27 @@ define Device/cudy_x6
endef
TARGET_DEVICES += cudy_x6
+define Device/dlink_dap-x1860-a1
+ $(Device/dsa-migration)
+ IMAGE_SIZE := 53248k
+ DEVICE_VENDOR := D-Link
+ DEVICE_MODEL := DAP-X1860
+ DEVICE_VARIANT := A1
+ UBINIZE_OPTS := -E 5
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ KERNEL_SIZE := 8192k
+ KERNEL_LOADADDR := 0x82000000
+ KERNEL := kernel-bin | relocate-kernel 0x80001000 | lzma | \
+ fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb
+ IMAGES += factory.bin
+ IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
+ IMAGE/factory.bin := append-kernel | pad-to $$(KERNEL_SIZE) | append-ubi | \
+ check-size | elx-header 011b0060 8844A2D168B45A2D
+ DEVICE_PACKAGES := kmod-mt7915-firmware rssileds
+endef
+TARGET_DEVICES += dlink_dap-x1860-a1
+
define Device/dlink_dir-8xx-a1
$(Device/dsa-migration)
IMAGE_SIZE := 16000k