aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorChuncheng Chen <ccchen1984@gmail.com>2022-06-14 14:11:52 +0800
committerChristian Lamparter <chunkeey@gmail.com>2022-06-25 10:14:18 +0200
commit8c00fd9b4519bf0ef8fb3470a6df421b9f38c03c (patch)
tree81b9dadd2659dd532432fa00fd93f0d102e5baec /target/linux/ramips/image
parente0d8f7ef1ff8ff93b8b55006f2f29749cdcc0aec (diff)
downloadupstream-8c00fd9b4519bf0ef8fb3470a6df421b9f38c03c.tar.gz
upstream-8c00fd9b4519bf0ef8fb3470a6df421b9f38c03c.tar.bz2
upstream-8c00fd9b4519bf0ef8fb3470a6df421b9f38c03c.zip
ramips: add support for ASUS RT-AX53U
Specifications: - Device: ASUS RT-AX53U - SoC: MT7621AT - Flash: 128MB - RAM: 256MB - Switch: 1 WAN, 3 LAN (10/100/1000 Mbps) - WiFi: MT7905 2x2 2.4G + MT7975 2x2 5G - Ports: USB 3.0 - LEDs: 1x POWER (blue, configurable) 3x LAN (blue, configurable) 1x WAN (blue, configurable) 1x USB (blue, not configurable) 1x 2.4G (blue, not configurable) 1x 5G (blue, not configurable) Flash by U-Boot TFTP method: - Configure your PC with IP 192.168.1.2 - Set up TFTP server and put the factory.bin image on your PC - Connect serial port(rate:115200) and turn on AP, then interrupt "U-Boot Boot Menu" by hitting any key Select "2. Upgrade firmware" Press enter when show "Run firmware after upgrading? (Y/n):" Select 0 for TFTP method Input U-Boot's IP address: 192.168.1.1 Input TFTP server's IP address: 192.168.1.2 Input IP netmask: 255.255.255.0 Input file name: openwrt-ramips-mt7621-asus_rt-ax53u-squashfs-factory.bin - Restart AP aftre see the log "Firmware upgrade completed!" Signed-off-by: Chuncheng Chen <ccchen1984@gmail.com> (replaced led label, added key-* prefix to buttons, added note about BBT) Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 68d054f960..b2b6f6b4cd 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -232,6 +232,23 @@ define Device/asus_rt-n56u-b1
endef
TARGET_DEVICES += asus_rt-n56u-b1
+define Device/asus_rt-ax53u
+ $(Device/dsa-migration)
+ DEVICE_VENDOR := ASUS
+ DEVICE_MODEL := RT-AX53U
+ IMAGE_SIZE := 51200k
+ UBINIZE_OPTS := -E 5
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ KERNEL_SIZE := 4096k
+ IMAGES += factory.bin
+ IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
+ IMAGE/factory.bin := append-kernel | pad-to $$(KERNEL_SIZE) | append-ubi | \
+ check-size
+ DEVICE_PACKAGES := kmod-mt7915e kmod-usb3 uboot-envtools
+endef
+TARGET_DEVICES += asus_rt-ax53u
+
define Device/beeline_smartbox-flash
$(Device/dsa-migration)
$(Device/uimage-lzma-loader)