aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorVolodymyr Puiul <volodymyr.puiul@gmail.com>2022-06-22 16:41:36 +0400
committerHauke Mehrtens <hauke@hauke-m.de>2022-10-31 22:01:49 +0100
commit08e153c3c31a117de0d47586ea7ab720ef95104b (patch)
treeea94ef82434651731aeffbf4fbbbdfd51db5747e /target/linux/ramips/image
parent7fd764dc5225e853e732cc091533dbaee6dc5419 (diff)
downloadupstream-08e153c3c31a117de0d47586ea7ab720ef95104b.tar.gz
upstream-08e153c3c31a117de0d47586ea7ab720ef95104b.tar.bz2
upstream-08e153c3c31a117de0d47586ea7ab720ef95104b.zip
ramips: add support for YunCore FAP690
It is an in-wall 802.11ax (Wi-Fi 6) router, based on MediaTek MT7621A. Specifications: - SoC: MT7621AT (880MHz, 2 Cores) - RAM: 128 MB - Flash: 16 MB SPI NOR - Wi-Fi: - MT7915DN + MT7905DAN: 2.4/5 GHz - Ethernet: 1x 1GiE via MT7530 - UART: J4 (115200 baud) - Pinout: [3V3] (TXD) (RXD) (GND) - Bootloader: U-Boot - Buttons: - SW1 - no label on the box, combined with led - Led: Status. RGB controlled by - GPIO 14 - green color - GPIO 15 - red color - GPIO 16 - blue color Installation: OEM firmware is based on LEDE with custom UI and support standard sysupgrade variant of firmware. However it requires "*.ubin" extension for sysupgrade file. Always select "Factory reset" switch on upgrade to OpenWRT, otherwise it will not boot. MAC addresses as verified by OEM firmware: vendor source LAN factory 0x4 (label) 5g factory 0x4 (label) 2g label with flipped bits bit in 1-st byte and bits 5, 6, 7 in 4-th byte Example label: 44:xx:xx:b7:xx:xx lan: 44:xx:xx:b7:xx:xx 2g 46:xx:xx:c7:xx:xx 5g 44:xx:xx:b7:xx:xx Signed-off-by: Volodymyr Puiul <volodymyr.puiul@gmail.com>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 46b30f01af..3ef4cf4efb 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -2273,6 +2273,16 @@ define Device/yuncore_fap640
endef
TARGET_DEVICES += yuncore_fap640
+define Device/yuncore_fap690
+ $(Device/dsa-migration)
+ $(Device/uimage-lzma-loader)
+ IMAGE_SIZE := 15808k
+ DEVICE_VENDOR := YunCore
+ DEVICE_MODEL := FAP690
+ DEVICE_PACKAGES := kmod-mt7915e
+endef
+TARGET_DEVICES += yuncore_fap690
+
define Device/zbtlink_zbt-we1326
$(Device/dsa-migration)
$(Device/uimage-lzma-loader)