aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorNita Vesa <werecatf@outlook.com>2022-04-29 13:57:24 +0300
committerDavid Bauer <mail@david-bauer.net>2022-08-09 21:22:41 +0200
commitca58b8b4feb7a56e262be7260032a06032264a48 (patch)
tree693572ccfbd00fd256e6e3fcd190da7b80b7877b /target/linux/ramips/image
parent707ec48ab3db6d08bd022df1bc720aee68b3b99d (diff)
downloadupstream-ca58b8b4feb7a56e262be7260032a06032264a48.tar.gz
upstream-ca58b8b4feb7a56e262be7260032a06032264a48.tar.bz2
upstream-ca58b8b4feb7a56e262be7260032a06032264a48.zip
ramips: Add Xiaomi Mi Router 4A 100M International
The international version of Mi Router 4A 100M is physically identical to the non-international one, but appears to be using a different partitioning scheme with the "overlay" partition being 2MiB in size instead of 1MiB. This means the following "firmware" partition starts at a different address and the DTS needs to be adjusted for the firmware to work. Signed-off-by: Nita Vesa <werecatf@outlook.com> (cherry picked from commit 1a8c74da709190e5157af9f5c2502b600f6273bb) Signed-off-by: Tom Herbers <freifunk@tomherbers.de>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt76x8.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 81b68f6354..2106324684 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -902,6 +902,16 @@ define Device/xiaomi_mi-router-4a-100m
endef
TARGET_DEVICES += xiaomi_mi-router-4a-100m
+define Device/xiaomi_mi-router-4a-100m-intl
+ IMAGE_SIZE := 14976k
+ DEVICE_VENDOR := Xiaomi
+ DEVICE_MODEL := Mi Router 4A
+ DEVICE_VARIANT := 100M International Edition
+ DEVICE_PACKAGES := kmod-mt76x2
+ SUPPORTED_DEVICES += xiaomi,mir4a-100m-intl
+endef
+TARGET_DEVICES += xiaomi_mi-router-4a-100m-intl
+
define Device/xiaomi_mi-router-4c
IMAGE_SIZE := 14976k
DEVICE_VENDOR := Xiaomi