aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorMarcin Gordziejewski <openwrt@flicksfix.com>2022-04-08 00:29:20 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2022-05-17 21:14:23 +0200
commit7152bc84f4adc750112bc426244e93cba8d2a922 (patch)
treebc54438bb6bb8f221da033c912457569bf7fceb8 /target/linux/ramips/image
parentd627ea510c36c2d2049bc062d236aea2c23bd636 (diff)
downloadupstream-7152bc84f4adc750112bc426244e93cba8d2a922.tar.gz
upstream-7152bc84f4adc750112bc426244e93cba8d2a922.tar.bz2
upstream-7152bc84f4adc750112bc426244e93cba8d2a922.zip
ramips: add support for TP-Link RE650 v2
TP-Link RE650 v2 is largely similar to v1 that is already supported by OpenWrt. Notable differences is differnt SPI Flash - 8 MB instead of 16 MB (from cFeon instead of Winbond) and a different configuration of PCIE connections to wifi chips. Otherwise it's largely the same product as v1 Hardware specification: - SoC 880 MHz - MediaTek MT7621AT - 128 MB of DDR3 RAM - 8 MB - cFeon QH64A-104HIP - 4T4R 2.4 GHz - MediaTek MT7615E - 4T4R 5 GHz - MediaTek MT7615E - 1x 1 Gbps Ethernet - MT7621AT integrated - 7x LEDs (Power, 2G, 5G, WPS(x2), Lan(x2)) - 4x buttons (Reset, Power, WPS, LED) - UART pinout - GND, RX, TX, labeled in the middle of the PCB, requires soldering because they're not through holes. Serial console @ 57600,8n1 Flash instructions: Upload openwrt-ramips-mt7621-tplink_re650-v2-squashfs-factory.bin from the RE650 web interface. TFTP recovery to stock firmware: I didn't try recovering back to the stock firmware, however, if there is such process for other RExxx devices, it seems like it could be similar here. Signed-off-by: Marcin Gordziejewski <openwrt@flicksfix.com> (cherry picked from commit 39799974a372fb4333d21f077c670b8a56b9d696)
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index bd0d6ad654..369ff520a3 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -1633,6 +1633,17 @@ define Device/tplink_re650-v1
endef
TARGET_DEVICES += tplink_re650-v1
+define Device/tplink_re650-v2
+ $(Device/dsa-migration)
+ $(Device/tplink-safeloader)
+ DEVICE_MODEL := RE650
+ DEVICE_VARIANT := v2
+ DEVICE_PACKAGES := kmod-mt7615e kmod-mt7615-firmware
+ TPLINK_BOARD_ID := RE650-V2
+ IMAGE_SIZE := 7994k
+endef
+TARGET_DEVICES += tplink_re650-v2
+
define Device/tplink_tl-wpa8631p-v3
$(Device/dsa-migration)
$(Device/tplink-safeloader)