aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-04-07 10:34:33 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-04-08 13:46:30 +0200
commitf761f4052c411bababed2d2e9d8dc3f43380e4ee (patch)
tree8436978a65ddb3d5dad2a504f77552a5eb79163f /target/linux/ramips/image
parent48b4aab80cd34682616bf7f12c41e35e27a49504 (diff)
downloadupstream-f761f4052c411bababed2d2e9d8dc3f43380e4ee.tar.gz
upstream-f761f4052c411bababed2d2e9d8dc3f43380e4ee.tar.bz2
upstream-f761f4052c411bababed2d2e9d8dc3f43380e4ee.zip
ramips: mt7621: harmonize naming scheme for Mikrotik
So far, image/device/board names for Mikrotik devices in mt7621 have been used quite inconsistently. This patch harmonizes the naming scheme by applying the same style as used lately in ath79, i.e. using "RouterBOARD" as separate word in the model name (instead of RB prefix for the number) and deriving the board/device name from that (= make lower case and replace spaces by hyphens). This style has already been used for most the model/DEVICE_MODEL variables in mt7621, so this is essentially just adjusting the remaining variables to that. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk18
1 files changed, 10 insertions, 8 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 0ecd70685b..ec9d8aacae 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -495,25 +495,27 @@ define Device/MikroTik
check-size
endef
-define Device/mikrotik_rb750gr3
+define Device/mikrotik_routerboard-750gr3
$(Device/MikroTik)
- DEVICE_MODEL := RouterBOARD RB750G
- DEVICE_VARIANT := r3
+ DEVICE_MODEL := RouterBOARD 750Gr3
DEVICE_PACKAGES += kmod-gpio-beeper
+ SUPPORTED_DEVICES += mikrotik,rb750gr3
endef
-TARGET_DEVICES += mikrotik_rb750gr3
+TARGET_DEVICES += mikrotik_routerboard-750gr3
-define Device/mikrotik_rbm11g
+define Device/mikrotik_routerboard-m11g
$(Device/MikroTik)
DEVICE_MODEL := RouterBOARD M11G
+ SUPPORTED_DEVICES += mikrotik,rbm11g
endef
-TARGET_DEVICES += mikrotik_rbm11g
+TARGET_DEVICES += mikrotik_routerboard-m11g
-define Device/mikrotik_rbm33g
+define Device/mikrotik_routerboard-m33g
$(Device/MikroTik)
DEVICE_MODEL := RouterBOARD M33G
+ SUPPORTED_DEVICES += mikrotik,rbm33g
endef
-TARGET_DEVICES += mikrotik_rbm33g
+TARGET_DEVICES += mikrotik_routerboard-m33g
define Device/mqmaker_witi
IMAGE_SIZE := 16064k