aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorBirger Koblitz <mail@birger-koblitz.de>2022-03-07 19:50:29 +0100
committerPetr Štetiar <ynezz@true.cz>2022-03-08 18:34:32 +0100
commited364cd4b03b289a7bb4b32c350c46eddeb6b6b9 (patch)
treec1ceb96f7c68e9470d9af08b6946cdac8c29876d /target/linux/ramips/image
parent62125c3ad51478c1bb9c237471ac04ea971bda6a (diff)
downloadupstream-ed364cd4b03b289a7bb4b32c350c46eddeb6b6b9.tar.gz
upstream-ed364cd4b03b289a7bb4b32c350c46eddeb6b6b9.tar.bz2
upstream-ed364cd4b03b289a7bb4b32c350c46eddeb6b6b9.zip
ramips: add support for Renkforce WS-WN530HP3-A
This adds support for the Renkforce WS-WN530HP3-A ceiling- mountable Wireless Access Point, which is powered over PoE. Hardware: - SoC: Mediatek MT7621DAT - RAM: 128MiB on SoC - Flash: 16MiB GigaDevice GD25Q128C - 2.4Ghz Wifi: Mediatek MT603EN - 5GHz Wifi: MT613BEN - Ethernet: - 1x 1GBit WAN port, passive PoE capable - 2x 1GBit LAN ports LEDs: 1x Bi-Color LED (red/blue) Buttons: 1x Reset Button, 1x Power Button Installation: Power on the access point and immedately press the reset button for 10 seconds. Connect web-browser to 192.168.10.1 and upload sysupgrade image. Flash uploaded image and wait about 2 minutes for reboot. Signed-off-by: Birger Koblitz <mail@birger-koblitz.de> Signed-off-by: Petr Štetiar <ynezz@true.cz> [fixed SoB]
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 1b7d095fc4..011a96a59e 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -1359,6 +1359,17 @@ define Device/raisecom_msg1500-x-00
endef
TARGET_DEVICES += raisecom_msg1500-x-00
+define Device/renkforce_ws-wn530hp3-a
+ $(Device/dsa-migration)
+ DEVICE_VENDOR := Renkforce
+ DEVICE_MODEL := WS-WN530HP3-A
+ DEVICE_PACKAGES += kmod-mt7603 kmod-mt7615e kmod-mt7663-firmware-ap
+ IMAGE/sysupgrade.bin := append-kernel | pad-to 65536 | append-rootfs | \
+ check-size | append-metadata
+ IMAGE_SIZE := 15040k
+endef
+TARGET_DEVICES += renkforce_ws-wn530hp3-a
+
define Device/samknows_whitebox-v8
$(Device/dsa-migration)
IMAGE_SIZE := 16064k